0

I wish to upgrade MySQL 5.5 to 5.6 on my CentOS 6.6 server and I am receiving an error after command yum update mysql as per the below output.

I am following the guide here. I have also tried to rectify the issue by using the further troubleshoot guide here, sadly that did not resolve the issue.

Error output

Error: Package: php-mysql-5.4.45-14.el6.remi.x86_64 (@remi)
           Requires: libmysqlclient.so.18(libmysqlclient_16)(64bit)
           Removing: mysql-libs-5.5.60-1.el6.remi.x86_64 (@remi)
               libmysqlclient.so.18(libmysqlclient_16)(64bit)
           Obsoleted By: mysql-community-libs-5.6.40-2.el6.x86_64 (mysql56-community)
               Not found

Detailed output

yum update mysql
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
epel/metalink                                            |  32 kB     00:00
 * epel: ftp.uni-stuttgart.de
 * remi-safe: mirror.23media.de
CityFan                                                  | 2.9 kB     00:00
PLESK_17_8_11-extras                                     | 2.9 kB     00:00
PLESK_17_PHP52                                           | 2.9 kB     00:00
PLESK_17_PHP53                                           | 2.9 kB     00:00
PLESK_17_PHP54                                           | 2.9 kB     00:00
PLESK_17_PHP55                                           | 2.9 kB     00:00
PLESK_17_PHP56                                           | 2.9 kB     00:00
PLESK_17_PHP70                                           | 2.9 kB     00:00
base                                                     | 3.7 kB     00:00
extras                                                   | 3.4 kB     00:00
mysql-connectors-community                               | 2.5 kB     00:00
mysql-tools-community                                    | 2.5 kB     00:00
mysql56-community                                        | 2.5 kB     00:00
plesk-migrator                                           | 2.9 kB     00:00
plesk-migrator-tp                                        | 2.9 kB     00:00
remi-safe                                                | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.60-1.el6.remi will be obsoleted
--> Processing Dependency: real-mysql(x86-64) = 5.5.60-1.el6.remi for package: mysql-server-5.5.60-1.el6.remi.x86_64
---> Package mysql-community-client.x86_64 0:5.6.40-2.el6 will be obsoleting
--> Processing Dependency: mysql-community-libs(x86-64) >= 5.6.10 for package: mysql-community-client-5.6.40-2.el6.x86_64
--> Running transaction check
---> Package mysql-community-libs.x86_64 0:5.6.40-2.el6 will be obsoleting
--> Processing Dependency: mysql-community-common(x86-64) >= 5.6.10 for package: mysql-community-libs-5.6.40-2.el6.x86_64
---> Package mysql-community-server.x86_64 0:5.6.40-2.el6 will be obsoleting
--> Processing Dependency: libnuma.so.1(libnuma_1.2)(64bit) for package: mysql-community-server-5.6.40-2.el6.x86_64
--> Processing Dependency: libnuma.so.1(libnuma_1.1)(64bit) for package: mysql-community-server-5.6.40-2.el6.x86_64
--> Processing Dependency: libnuma.so.1()(64bit) for package: mysql-community-server-5.6.40-2.el6.x86_64
---> Package mysql-libs.x86_64 0:5.5.60-1.el6.remi will be obsoleted
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: php-mysql-5.4.45-14.el6.remi.x86_64
---> Package mysql-server.x86_64 0:5.5.60-1.el6.remi will be obsoleted
--> Running transaction check
---> Package mysql-community-common.x86_64 0:5.6.40-2.el6 will be installed
---> Package mysql-libs.x86_64 0:5.5.60-1.el6.remi will be obsoleted
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: php-mysql-5.4.45-14.el6.remi.x86_64
---> Package numactl.x86_64 0:2.0.9-2.el6 will be installed
--> Finished Dependency Resolution
Error: Package: php-mysql-5.4.45-14.el6.remi.x86_64 (@remi)
           Requires: libmysqlclient.so.18(libmysqlclient_16)(64bit)
           Removing: mysql-libs-5.5.60-1.el6.remi.x86_64 (@remi)
               libmysqlclient.so.18(libmysqlclient_16)(64bit)
           Obsoleted By: mysql-community-libs-5.6.40-2.el6.x86_64 (mysql56-community)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
0

You may have to roll back some of the packages to a previous version to install the package your looking to install. I know I had a similar issue when I tried to upgrade CentOS from 7.4 to 7.5. A package from EPEL was ahead of a package in updates repository and the upgrade wouldn't run. I had to roll back that package to the version in the updates repository.

an example of the yum command can be found at "How to check available package versions in rpm systems?" for checking to see what packages are avalible to rollback to.

yum --showduplicates list <package>

when you find the package your looking for, you type yum downgrade <package-name-version>

Then after the downgrade, you proceed with the upgrade your trying to complete focus on the package your trying to install then the rest of the system.

In your case:

[thebtm@server ~]# yum --showduplicates list php-mysql
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.it.ubc.ca
 * epel: muug.ca
 * extras: mirror.it.ubc.ca
 * ius: mirrors.kernel.org
 * updates: mirror.it.ubc.ca
Available Packages
php-mysql.x86_64          5.4.16-45.el7            base 
[thebtm@server ~]# yum downgrade php-mysql --disablerepo=remi-safe
3
  • Thank you @thebtm for the instructions, I'll give this a try and report back. Jul 18 '18 at 10:25
  • Hi thebtm, I get the output 'installed packages 5.4.45.e16.remi @remi available packages 5.3.3-49.e16 base' The latest SQL version I have installed though is 5.5... unsure of whether to run the downgrade? Jul 22 '18 at 5:34
  • what happens when you run the downgrade command with the remi repo disabled? are you able to clone the machine and test it?
    – thebtm
    Jul 25 '18 at 17:24
0

Actually its because of the reason you have remi rpm installed. First you have to get rid of remi repolist.

First run "yum repolist" it will give you all installed repo lists.

Then remove remi stuff with

"rpm -e --nodeps remi*"

Then, remove all conflicting rpms like "php-mysql-5.4.45-14.el6.remi.x86_64", "yum remove php-mysql" reinstall them. "yum install php-mysql"

And you are good to go, try again with "yum update mysql"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.