My WiFi connection just disappeared. I cannot find any network by GUI, but:

$ iw wlan0 scan

shows nearby networks. Also restarting NetworkManager by few ways (service ... restart or systemctl stop NetworkManager.service and then disable, enable, start) didn't help.

Using Dell E7440, Debian stretch.

Any ideas?


result of ip link:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00  
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether ec:f4:bb:62:af:80 brd ff:ff:ff:ff:ff:ff  
3: wwp0s20u7c2i12: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether fe:16:26:8b:16:c1 brd ff:ff:ff:ff:ff:ff  
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 5a:62:db:85:8e:84 brd ff:ff:ff:ff:ff:ff

in /etc/modprobe.d/ there is no iwlwifi.conf file, but just modsetting.conf. (Somebody posted a comment about that but now I can't see it...) I had to add those lines to that:

options iwlwifi 11n_disable=1 swcrypto=1   

I made a backup of modesetting.conf and made iwlwifi.conf with that commands. Didn't help.


The command:

$ nmcli dev status

gives me:

eth0     ethernet connected    eth0  
cdc-wdm1 gsm      disconnected --  
wlan0    wifi     unavailable  --  
lo       loopback unmanaged    --   
  • I've been trying: > /etc/init.d/networking force-reload > service network-manager restart > service network-manager force-reload iw wlan0 scan dump > nothing (with sudo; as user: iw command not found) results of ip link in main post Link from wiki: I have no such file, in that folder I can see just: modesetting.conf. Adding proposed line didn't help – Morales1235 Jul 18 '18 at 15:44
  • I had much more luck with nmcli than iw/iwconfig, although I never checked the why. – peterh says reinstate Monica Jul 20 '18 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.