17

Im pretty new to Kde 4.8 and I can not figure out how to get this behaviour that I used to have in Gnome:

  1. Desktop 1: developer/misc (browser, editor/ide, diff, etc..)
  2. Desktop 2: virtual machines (vbox)
  3. Desktop 3: graphic (gimp, inkscape, phatch)
  4. Desktop 4: file management (ftp, ssh, etc..)

In gnome is possible to configure the windows to always appear in a specific desktop, and this is what I want to achieve in Kde.

I googled around so much, and looks like activities can't do that (yet), becose using the window's menu only works for the current session, and get lost after reboot.

By the way, I suppose that activities can do that, becose in the default activities that come with Kde 4.8 Gimp used to show only in the photo activity (I gave a look to the activity configuration but I didn't find anything about this behavior).

Onestly, my goal is to obtain this scenario, if it is not possible with activities but with desktops, for me is ok.

So, any idea on how to obtain this behavior in Kde 4.8?

I already read this similar question, but im looking for a permanent solution.

20

This (and much much more) can be done in advanced settings of KDE's window manager KWin. You can get to it if you right click on window titlebar and select Advanced > Special Application Settings (or Special Window Settings if you would like to apply only to specific window and not all windows of this app). Then on the Size and Position tab you can force it to open on specific virtual desktop or in specific activity (for activities you need KDE software compilation version 4.9, if I remember correctly).

1
  • this only works on kde windows. for apps that don't go through kde, it doesn't work.
    – thang
    May 12 '19 at 7:11
3

For 4.13.3, you right click on the window title bar and select More Actions -> Special Application Settings. This will open up a dialog with the tab "Size & Position". There will be a check box "Activity" with options to restrict the window to an activity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.