2

This question already has an answer here:

I am working on a piece of Python code on my Windows 10 Pro machine, but need a package that is only available on Mac and Linux. I have used SSH to connect to a Linux machine in the lab I work in (interestingly enough, even though Google tells me I shouldn't be able to SSH directly from my Windows terminal instead of something like Putty, I can...?) and am trying to copy over a test .py file, so I can see if I can code on my laptop, copy the files over, and run the files through SSH on the Linux machine. However, when I try to use scp, this appears in the terminal (Including what I typed in so you can see if maybe I'm doing something wrong):

$ scp /Desktop/Everything-else/Python/scp-test.py rmanton2@[computer address]:/home/rmanton2/Desktop/Python
rmanton2@[computer address]'s password:
stdin: is not a tty
/Desktop/Everything-else/Python/scp-test.py: Permission denied

Why does this happen? My googling has either produced results that don't apply to my situation or that I don't understand (I've never really done much with my computer besides using the Internet, this is the first time I've done anything with the terminal.) If someone could explain exactly what I can do to fix this in a simple way, I'd really appreciate it.

I'm an admin AND the only user account on my laptop, so I don't know why I wouldn't have permission to access it. When googling to find solutions to the tty issue, I couldn't find any that I actually understood well enough to work. (There was one that had a block of code to run, but it had a '...' to indicate something else should be put there, and I had no idea what... My question has been marked as a possible duplicate of that question, but as I said, that didn't help me, and I doubt commenting on a 5 year old post will get me many answers.)

If it's necessary info, the OS on the Linux machine is ScientificLinux 6.9.

marked as duplicate by roaima, thrig, meuh, schily, Romeo Ninov Jul 16 '18 at 19:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Edit: I seem to have found an answer. I had to use scp from my own computer rather than first using ssh to get into the other computer, and I had to change directory so the prompt said "C:>" instead of "C:\Users\Reka>". I still get "stdin: is not a tty", but the file appeared in the correct file on the other computer. I swear I tried this before, but I guess I did something different.

Not the answer you're looking for? Browse other questions tagged or ask your own question.