1

I was using Linux Mint 18.3 Cinnamon, and now I have a fresh Linux Mint 19 Cinnamon. My / and /home directories were separate, so I left my /home from previous OS.

My problem is that my Sound settings are not detecting sound device. Even after fresh install the problem still occurs.

I have tried this, this, and this, but couldn't solve the problem.

~ $ lspci -v | grep -i audio
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
    Subsystem: ASUSTeK Computer Inc. Haswell-ULT HD Audio Controller
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
    Subsystem: ASUSTeK Computer Inc. 8 Series HD Audio Controller

.

 ~ $ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC3236 Analog [ALC3236 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

.

~ $ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7a1c000 irq 51
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7a18000 irq 50

P.S. On my secondary Windows 10 OS sound works great.

4
  • What does pacmd info say? Jul 16, 2018 at 9:35
  • @IgnacioVazquez-Abrams No PulseAudio daemon running, or not running as session daemon.
    – mend4x
    Jul 16, 2018 at 9:38
  • 1
    Your ALSA hardware seems to be fine (verify with aplay -D hw:1 whatever.wav, must be a WAV file). So the Problem seems to be that Pulseaudio doesn't start, which may be required by your Desktop for you "sound settings". A possible culprit are leftover config files (which start with a dot . in your home directory) which don't match the current version of whatever program in the chain that should start Pulseaudio fails.
    – dirkt
    Jul 16, 2018 at 10:13
  • @dirkt your hint about config files helped. It was because of this problem. I fixed permissions for my config folder and then it worked. thanks!
    – mend4x
    Jul 16, 2018 at 10:42

1 Answer 1

1

Your ALSA hardware seems to be fine (verify with aplay -D hw:1 whatever.wav, must be a WAV file). So the problem seems to be that Pulseaudio doesn't start, which may be required by your Desktop for you "sound settings". A possible culprit are leftover config files (which start with a dot . in your home directory) which don't match the current version of whatever program in the chain that should start Pulseaudio fails.

(By comment of OP, it turned out to be a permission problem in the config folder.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .