18

I'm using linux mint with Cinnamon. The login screen comes to type a username but it also displays that in 10 seconds userx will be automatically logged in.

And it happens.

How to make it wait indefinitely?

2
  • Running Gnome Display Manager? (GDM)
    – Tim
    Aug 15, 2012 at 19:39
  • Mint uses MDM a new Display Manager, which code is based on GDM 2.20.
    – John Eipe
    Aug 16, 2012 at 19:20

8 Answers 8

12

Edit

/etc/mdm/mdm.conf

and set

AutomaticLoginEnable=false
3
  • after restart works great! I was able to remove timedlogin from the same file.
    – Nick
    Mar 15, 2013 at 15:55
  • Not sure what version of Mint this applies, presumably 13.x or earlier; the file doesn't exist in my install of Mint 18.3. Other answers to this question seem to work better for newer versions of Mint. Jul 18, 2018 at 11:28
  • For newer versions: unix.stackexchange.com/a/179950/253746 Dec 29, 2020 at 8:17
8

Open 'Menu' > 'Login Window' to open the Login Window Preferences. Select the 'Security' tab > uncheck the 'Enable Automatic Login' option.

2
  • This worked for 17 (Rosa)
    – RyanNerd
    Feb 8, 2016 at 19:49
  • In Mint 19 (Tessa), I needed to remove the username from "Automatic login". Now, if I suspend, upon waking I do not require a password. Am I supposed to lock the screen before suspending?
    – ahorn
    Jun 22, 2019 at 14:50
5

That was not enough. For some weird reason Mint added a user by default to the nopasswdlogin group and no mater how long you play with the settings above, that user will not be challenged for a password.

Solution: Go to Menu > Administration > Users and Groups and remove that user from the nowpasswdlogin group.

1
  • thanks! this was the only thing that worked for me today.
    – Ingvald
    Oct 14, 2015 at 17:58
4

To me, disabling "Enable Automatic Login" in "Auto Login" tab from Login Window Preferences wasn't enough (login screen was showing up, but a moment later system was automatic logging me). I had to uncheck also "Enable Timed Login" from the same section.

1

In Mint 17/18 you need to go to Users and Groups, select the user in question from the menu on the left, then next to "Password" on the right, click "Change..." and make sure "Don't ask for password on login" is unchecked.

1
  • after restart the problem appears again. It does not fix.
    – Sigur
    May 3, 2018 at 13:28
1

This worked for me. Open the file

sudo xed /etc/lightdm/lightdm.conf

and remove the following lines

autologin-user=<user>
autologin-user-timeout=0
1
  • Worked like a charm. Needed to remove autoboot to fix the keyring issue. Everything worked as it should on restart. Thanks!
    – Mobi Zaman
    Nov 21, 2021 at 17:38
0

In Mint 16 Petra you need to turn on time delay for nopasswlogin user.

1
  • Can you show an example of how this should be done?
    – Graeme
    Feb 23, 2014 at 11:54
-2

In linux Mint 20.2 (Cinnamon 5) you need to type in your terminal:

$ sudo xed /etc/lightdm/lightdm.conf

autologin-user=false

Must be "false"

2
  • I wonder whether that means that it should try to automatically login a user named false, and that it fails (silently?) if there is no such user. antikbd already suggested deleting the autologin-user= line altogether. Do you believe that your answer is better? Why? Jan 6, 2022 at 18:52
  • This could only possibly affect a GUI login. In fact, you need to do more than this - see other answers. Jan 6, 2022 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .