4

I use a Sony Vaio Tap 11 (Intel based tablet) with Debian Gnome, but experience the same issue under Ubuntu, Arch, Fedora etc. . This tablet has a radio keyboard with touchpad and two buttons connected by magnets.

When I press one of the mouse buttons xinput detects the button press, but after physically releasing the button xinput does not detect any button release. This is the case for both mouse buttons and clicking on the mouse pad. When I suspend and turn on again with running xinput test, xinput detects both buttons released.

I made sure that synaptics is deinstalled (was installed automatically, but not used). => no change I checked which libinput packages and found that libinput5 is not installed and also not available via apt-get.

libinput-bin/stable,now 1.6.3-1 amd64  [Installiert,automatisch]
libinput-dev/stable 1.6.3-1 amd64
libinput-pad-dev/stable 1.0.3-1+b1 amd64
libinput-pad-xtest/stable 1.0.3-1+b1 amd64
libinput-pad1/stable 1.0.3-1+b1 amd64
libinput-tools/stable 1.6.3-1 amd64
libinput10/stable,now 1.6.3-1 amd64  [Installiert,automatisch]
xserver-xorg-input-libinput/stable,now 0.23.0-2 amd64  [Installiert,automatisch]
xserver-xorg-input-libinput-dev/stable 0.23.0-2 all

Here what xinput shows after pressing button 1, moving around on the mousepad, suspending and turning on again:

ck@CKsVaioTap11debian:~$ xinput test 17
button press   1 
motion a[1]=807 
motion a[1]=808 
motion a[1]=810 
motion a[1]=813 
motion a[1]=815 
motion a[1]=817 
motion a[1]=819 
motion a[0]=1522 a[1]=821 
motion a[0]=1523 a[1]=823 
motion a[0]=1525 a[1]=825 
motion a[0]=1528 a[1]=826 
button release 1 

And here the xinput output:

ck@CKsVaioTap11debian:~$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Sony Vaio Jogdial                         id=9    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=13   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                     id=14   [slave  pointer  (2)]
⎜   ↳ Cypress Semiconductor WUSB NL Dongle V1.81    id=17   [slave  pointer  (2)]
⎜   ↳ N-trig DuoSense                           id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sony Vaio Keys                            id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ N-trig DuoSense Pen                       id=11   [slave  keyboard (3)]
    ↳ Front Camera                              id=15   [slave  keyboard (3)]
    ↳ Cypress Semiconductor WUSB NL Dongle V1.81    id=16   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=19   [slave  keyboard (3)]
    ↳ Sony Vaio Jogdial                         id=20   [slave  keyboard (3)]
    ↳ Logitech USB Receiver                     id=21   [slave  keyboard (3)]
    ↳ Cypress Semiconductor WUSB NL Dongle V1.81    id=22   [slave  keyboard (3)]
    ↳ Rear Camera                               id=18   [slave  keyboard (3)]

Does anyone has an idea what I can do to get the mousebuttons to be released after press? Under windows and old Ubuntu distris the mouse buttons worked properly. Also with an older debian live system the mouse buttons worked, but not after I installed that distri. Clicking the touchscreen works as expected. Mouse attached via usb (e.g. logitech) works also as expected. Had a look into gsettings does not show anything unexpected:

gsettings list-recursively org.gnome.desktop.peripherals.touchpad
org.gnome.desktop.peripherals.touchpad send-events 'enabled'
org.gnome.desktop.peripherals.touchpad natural-scroll true
org.gnome.desktop.peripherals.touchpad two-finger-scrolling-enabled true
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad click-method 'areas'
org.gnome.desktop.peripherals.touchpad speed 0.0
org.gnome.desktop.peripherals.touchpad tap-to-click false
org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled false


cat /proc/version 
Linux version 4.9.0-6-amd64 (debian-kernel@lists.debian.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07)
0

No clue if this works for you, but my laptop+mouse sometimes suffer the same problem and I accidentally found out it can be fixed by tapping the touch screen once. Afterwards, the mouse works as expected and the button gets released again.

Worth a try I think :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.