5

I've installed Lubuntu (not Ubuntu) in a VMWare Workstation VM. Version 18.04.

I'm getting a startup warning message I always get on my Ubuntu installs:

piix4_smbus: 000:00:07.3 SMBus Host Controller not enabled!

However, my usual fix of adding blacklist i2c-piix4 to blacklist.conf doesn't appear to work on the Lubuntu install.

Any idea why it doesn't work in Lubuntu and/or how to remove the warning from Lubuntu startup?

10

After blacklisting piix4_smbus, run update-initramfs -u.

I don't remember off the top of my head which storage controller drivers are used in a VMware virtual machine, but ata_piix is a very likely candidate.

If the initramfs generator only does simple string matching on module names, it might be picking up i2c-piix4 in addition to the ata_piix storage driver and including it into initramfs. And so it could get loaded before the system can see the root filesystem and its /etc/modprobe.d/blacklist.conf.

Updating the initramfs will include the files in /etc/modprobe.d/ into initramfs, so piix4_smbus should then be blacklisted during the initramfs boot phase too.

1
  • 2
    In Debian/Ubuntu, initramfs-tools package (with update-initramfs as its primary command) is the standard initramfs generator. RHEL 7 and some other new distributions are using dracut instead as an initramfs generator, and it is available in Debian 9 as an alternative choice too. Essentially an initramfs generator is just a program or script that more or less automatically gathers up all the things needed for mounting the root filesystem and builds an initramfs file out of them.
    – telcoM
    Jul 12 '18 at 17:53
0

Well I wanted to post this on a ubuntu forum, but didn't have enough reputation, so I just post it here (same error on kali linux)

So this just happend to me and I wanted to share it with y'all, perhaps it helps somebody:

So I run Kali Linux in a VMware enviroment on Windows and I was away from my computer. It went to sleep (while transfering files to a shared windows folder) and when I came back it only showed a black screen. So I did a restart but then a blue screen happend. After restarting my host I went and tried to power up the kali linux OS, then I got the following error:

Piix4_SMBus: 000:00:07.3: Host SMBus controller bus not enabled

not only that, it was stuck on a initramfs console. After trying all the stuff I found related to this error (adding the blacklist stuff in any imagionable way) I went back to the error. If you are in the initramfs console then type exit. It should show a error what is happening.

For me it showed that the /dev/sda1 had problems and I had to run fsck manually. What I did not mention before is that I managed to get inside the kali linux OS by adding the original ISO as a CD to VMware. I then entered the boot menu with F2 and changed the boot order to have CD on top.

You then get additional advanced boot options, also the recovery kali linux OS. (the graphical didn't work, just use the console one) follow all the steps and enter the /dev/sda1 as root console. Then type the following commands:

mount -o remount,ro /
fsck

it should do a fsck scan now and for me it showed a lot of errors. Just press enter on every error and then do a reboot. Change the boot order in the BIOS again and then it should boot normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.