0

In my /etc/apt/sources.list file:

deb http://debian.ruc.dk/rumd stretch main 
deb-src http://debian.ruc.dk/rumd stretch main

When I run sudo apt update I see

Ign:10 http://debian.ruc.dk/rumd stretch InRelease                                                         
Hit:11 http://dl.google.com/linux/chrome/deb stable Release                                                
Err:12 http://debian.ruc.dk/rumd stretch Release                                     
  404  Not Found
E: The repository 'http://debian.ruc.dk/rumd stretch Release' does not have a Release file.

EDIT: The error appears to be that there is no Release file. Is there a way to still download the package?

And when I run sudo apt install rumd I get

E: Unable to locate package rumd

The repository, however, seems perfectly accessible. What is going on? I am on Debian 9.4 stretch.

4
  • I suspect the issue is that repositories that do not provide a release file are now considered insecure by default. You may be able to work around it by passing the Acquire::AllowInsecureRepositories option or (perhaps better) marking the specific repo as [trusted=yes] in your sources.list. See man apt-secure for further details and make sure you understand the security implications. Jul 12, 2018 at 16:14
  • Thanks, I added [trusted=yes]. I see (among other, ignored, sources): Get:21 http://debian.ruc.dk/rumd stretch/main amd64 Packages [1,587 B] when I run apt update. However, if I run apt install rumd (as per their download page), I still get E: Unable to locate package rumd. Any idea?
    – Kappie001
    Jul 12, 2018 at 16:41
  • Do you have any foreign architectures enabled? dpkg --print-foreign-architectures Jul 12, 2018 at 17:04
  • ... if so, try making that deb [arch=amd64 trusted=yes] and then running apt update again Jul 12, 2018 at 17:22

1 Answer 1

0

The HTTP 404, 404 Not Found and 404 error message is a Hypertext Transfer Protocol (HTTP) standard response code, in computer network communications, to indicate that the client was able to communicate with a given server, but the server could not find what was requested.

The above is from Wikipedia

In your case, maybe you don't have connection to that page. You can just get another source.list and have a try. Hint: you can use the source in your country, which is faster in most case.

4
  • It says "E: The repository 'debian.ruc.dk/rumd stretch Release' does not have a Release file." Maybe that is the problem? I have an internet connection, what do you mean "maybe I don't have connection to that page?"
    – Kappie001
    Jul 12, 2018 at 15:11
  • @Kappie001 Just open that file and change the source. That's all what you can do. Jul 12, 2018 at 15:19
  • What do you mean "change the source?"
    – Kappie001
    Jul 12, 2018 at 15:32
  • 2
    I know how to edit a file from the command line. I cannot make out what your proposed solution to my problem is, though. Change debian.ruc.dk/rumd into what, exactly?
    – Kappie001
    Jul 12, 2018 at 15:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .