2

I use a laptop with Nvidia Optimus, and I'm running the newest Void Linux. Following instructions on its wiki and the Arch wiki, I got the desktop able to render via the GPU rather than the iGPU or CPU.

The problem is that it seems to have configured my default refresh rate wrong, here is xrandr:

    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.06 +  60.01    59.97    59.96*   59.93    40.04  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
HDMI-1-2 disconnected (normal left inverted right x axis y axis)

I can force "59.96" which mostly fixes the stuttering, with rare-ish exemptions, but the problem then is that some applications that love the defaults, like Overgrowth (some combat game from Steam), so it stutters like crazy due to that "60.06Hz" nonsense (EDIT2: found a fix by having the game run in a window and rebooting with edited monitor.xml settings [might not be needed] and forced xrandr refresh rate to 59.96Hz. Doesn't allow me to use fullscreen though which is annoying) (EDIT4: Can run the game in fullscreen now, but only in MATE when using Marco compositor and doing borderless window, still a bit inconvienent if I wanted to use KDE [my main GUI] or another non-i3 interface). I tried Arch's EDID fix, doesn't work. I tried forcing a framerate with a modeline from cvt, doesn't work. I hope changing monitors.xml will work, or I'll tear my head off. It might not though since "60" just makes things "60.06," causing horrible stuttering. I don't know how to fully fix this or even have all applications just use the more sensible 59.96Hz to satisfy the display. Is there any way to fix this?

EDIT: I'm also looking for a solution for even the slight stutter from using 59.96Hz, as it can still be somewhat annoying for obsessive types like me.

EDIT3: To make matters worse, it seems in display settings of both MATE and KDE, they think I can use 120Hz. That's how misconfigured the display is.

EDIT5: Monitors.xml does nothing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.