1

I have 2 GPUs, but my NVIDIA-SMI just shows me one. How can I make it recognize the other one?

enter image description here

  • nvidia-smi is a pain, are you with the newest drivers? I also strongly you to check the devtalk.nvidia.com forums – vfbsilva Jul 11 '18 at 18:40
  • it could be a bad GPU, try swapping the cards or cables around to see if the problem follows a particular GPU – thrig Jul 11 '18 at 22:50
0

I think GPU don't appears if is disabled. Check if "remove" file in your GPU device is empty. In your case, see next file; /sys/bus/pci/devices/0000:83:00.0/remove

If this folder doesn't exists your device hasn't started correctly. In this case, If is possible for you, try checking that this GPU have enough power and is correctly connected.

If there is 1 in the file, change it by a 0 and reboot. If the folder exists but the file don't contains the value of 1 You can check other files in this folder for more information about the device because your device starts and some other things are causing the faulure. Check using other older driver version as says vfbsilva.

Font: I disabled some GPUs manually and the results are similar. https://labernia.wordpress.com/2017/07/16/gpu-testing/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.