3

When I try to play audio in chromium (e.g. in google translate or any icecast radio station) it gives this error in terminal

[69:97:0711/164208.951104:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"FFmpegDemuxer: open context failed"}
[69:69:0711/164208.951234:ERROR:render_media_log.cc(30)] MediaEvent: PIPELINE_ERROR DEMUXER_ERROR_COULD_NOT_OPEN

Sound in video (e.g. youtube) still works without problems, so it happens only with audio tag.

My chromium version:

Chromium 67.0.3396.87 built on Debian 9.4, running on Debian 9.5

My ffmpeg version:

ffmpeg version 3.2.10-1~deb9u1 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 6.3.0 (Debian 6.3.0-18) 20170516
configuration: --prefix=/usr --extra-version='1~deb9u1' --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
libavutil      55. 34.101 / 55. 34.101
libavcodec     57. 64.101 / 57. 64.101
libavformat    57. 56.101 / 57. 56.101
libavdevice    57.  1.100 / 57.  1.100
libavfilter     6. 65.100 /  6. 65.100
libavresample   3.  1.  0 /  3.  1.  0
libswscale      4.  2.100 /  4.  2.100
libswresample   2.  3.100 /  2.  3.100
libpostproc    54.  1.100 / 54.  1.100

I still can download radio stations .m3u files and VLC (which also uses libav libraries) plays them without trouble. Playing audio via firefox works too.

0

I had the same problem. It happened after the last chromium upgrade. This is the email which described things changed in ~deb9u1.

livewire98801 suggests installing a different version of chromium. However installing packages from testing into stable is not advised:

Don't make a FrankenDebian

Debian Stable should not be combined with other releases.

Alternatively one can install an older version from debian stable. It contains the security patches but videos work with it:

➜  ~ apt list chromium -a
Listing... Done
chromium/stable,now 67.0.3396.87-1~deb9u1 amd64 [installed]
chromium/stable 62.0.3202.89-1~deb9u1 amd64

Running

apt install chromium=62.0.3202.89-1~deb9u1

installs the older version from stable (stretch).

  • Thank you. Audio works now. So I guess we just need to wait for another update to get it fixed in the newer version/ – Роман Чистоходов Jul 13 '18 at 13:00
0

This thread sounds like your issue, titled: Does anyone know how Chrome for Android or Android Webview plays facebooks videos?

adding these to your args.gn folder should enable the videos to play:

proprietary_codecs = true
ffmpeg_branding = "Chrome"

Reference: Turn on proprietary codecs in Chromium builds

  • I did not build chromium myserlf. It comes from distro repository. The audio worked before but just suddenly stopped, so it must be some environment problems. I just can't guess what's wrong. – Роман Чистоходов Jul 12 '18 at 10:36
0

I was having the same issue, I grabbed the package from Testing that had the same main version as the current, but without the ~deb9u1 tag:

$ apt list chromium -a
Listing... Done
chromium/testing,now 67.0.3396.87-1 amd64 [installed]
chromium/stable 67.0.3396.87-1~deb9u1 amd64
chromium/stable 62.0.3202.89-1~deb9u1 amd64

It seems to have solved my problems. Flickr videos are now working, Hangouts browser notifications are working, web page notifications are working... frustrating that someone would change something that important and it makes it all the way through to the main repos -_-

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.