2

I'm trying to connect an iPhone SE with iOS 11 to a Linux Debian 9.4 "Stretch" desktop with XFCE environment. I followed step-by-step about 5 different guides on the internet how to do so. I ended-up installing the packages: libimobiledevice ideviceinstaller and attempted to use their functionality however with no success.

I tried to mount my iPhone using both: idevicepair pair which replies with SUCCESS after trusting the computer, however when trying to actually access the device an error message will pop up citing:

Failed to mount "Documents on (my name)'s iPhone" Unhandled Lockdown error (-3)

I tried another approach by using ifuse to mount my iPhone to a local directory, but it didn't work either. It replies with an error message within the terminal citing:

Failed to connect to lockdownd service on the device. Try again. If it still fails try rebooting your device.

I tried to reboot my device, however it did not work at all. I also deleted the lockdown files according to another troubleshooting guide but it didn't work either, idevicepair just created new files which again resulted in this device lockdown error.

I to connect my iPhone to my desktop.

8
  • Is your phone unloked when you try to mount it?
    – YoMismo
    Jul 11, 2018 at 9:26
  • Unlocked in what sense? as in user PIN code? Oh yes, I didn't set one. It's also trusting my computer. Jul 11, 2018 at 9:54
  • Android phones are blocked and you need pattern/pin/fingerprint to unlock them, if they are locked then you can't mount them, that was the reason for the question.
    – YoMismo
    Jul 11, 2018 at 10:26
  • See the debian documentation : Configure the iPhone part and the mount-iphone.sh script
    – GAD3R
    Jul 11, 2018 at 10:33
  • 1
    @GAD3R, I just tried to run the mount-iphone.sh script, however it doesn't work, it yields exactly the same error message as with idevicepair: "Error mounting location: Unhandled Lockdown error (-3), iphone mount failed" Jul 12, 2018 at 5:09

1 Answer 1

-1

Everybody with this problem might have to get some latest libraries. On Debian this could mean that you have to download the sources an compile them on your machine by yourself. I recomment to try the recipe of Sam Rocketman: https://gist.github.com/samrocketman/70dff6ebb18004fc37dc5e33c259a0fc In my case it solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .