1

Running the command:

amixer -D pulse sset Master 30%

should set the audio volume to 30% right?

When running:

amixer get Master

It returns saying the audio volume is 52%.

Any explanation or solution to my problem? Thanks!

0

Pulseaudio has its own set of volume controls, and the pulse device is the converter that lets ALSA-only applications use Pulseaudio.

I very much doubt setting any mixer control on the pulse device does anything sensible. And I'm not sure which value reading mixer controls would return, possible the volume setting of the default sink (but I'd have to read the source code to find out).

If you want to control the volume of Pulseaudio applications from the commandline (no matter if they use Pulseaudio via ALSA, or directly), have a look at pacmd.

  • Hmmm intersting... However I've no idea on how to use pacmd to change the volume and get the volume. Can you please explain how to use it? Thanks – Gustavo Machado Jul 11 '18 at 12:42
  • See e.g. here, or one of the other similar questions. – dirkt Jul 11 '18 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.