0

I have downloaded the Ubuntu .iso and created a bootable USB drive. I have 3 drives: 1 1TB NVME with Windows 10 on it, 1 TB HDD, and a fresh 500 GB SSD that is GPT. I am trying to install Ubuntu on the fresh 500 GB SSD. Despite two full days of varying installation procedures and parameters, every attempt has been stalled by one error or another. I will try to elucidate the gist of what I have tried, but again, I have easily spent about 20-25 hours trying many different things and various solutions to the errors that have arisen for each step of the installation processes.

Despite following this tutorial: https://tutorials.ubuntu.com/tutorial/tutorial-install-ubuntu-desktop#7 . I have run into a number of errors. First, I try the simple installation and just click away. It appears to install fine. But after restarting my computer without the USB drive inserted, I am taken to the following screen:

enter image description here

I tried all of the solutions I could find:

  1. https://askubuntu.com/questions/705055/gpt-detected-please-create-a-bios-boot-partition

  2. https://askubuntu.com/questions/88384/how-can-i-repair-grub-how-to-get-ubuntu-back-after-installing-windows (the steps in this solution stopped working at around step 2 due to commands not being found)

    None worked.

I suppose the best answer would be a step-by-step guide to successfully install Ubuntu. All other guides/tutorials always give rise to one of the following errors:

  1. https://itsfoss.com/fix-minimal-bash-line-editing-supported-grub-error-linux/ (this solution did not work) https://askubuntu.com/questions/918581/cant-boot-any-os-after-installing-windows-gnu-grub-minimal-bash-like-line-edi https://askubuntu.com/questions/88384/how-can-i-repair-grub-how-to-get-ubuntu-back-after-installing-windows

I tried to manually address the GRUB CLI issue with a manual partitioning, but it didn't resolve the error message:

  1. https://help.ubuntu.com/community/DiskSpace#BIOS-Boot_or_EFI_partition_.28required_on_GPT_disks.29 https://superuser.com/questions/936889/booting-a-usb-from-the-grub-command-prompt/936915

On start-up, I also get a flashing screen, where it alternates between a black screen with text (see below) and just a blank, black screen.

enter image description here

So, yeah. A lot of problems. Any ideas?

  • Check for a new(er) installer. Follow the instructions step by step. If anything fails, please give full input and output, and what you expected (and why). Please don't direct us at outside web sites, as (a) they might go away, (b) be talking about some other problem, and finally but not least (c) because we are lazy bums. (Yes, make it as easy as possible on the would-be-helper, even if it means asking questions one step at a time). – vonbrand Jul 10 '18 at 17:55
0

Please try the find out the grub location in the grub2 command line (which you are getting now after reboot)

grub2> ls (hd0,1)/grub or grub2> ls (hd0,1)/boot/grub

If you are using efi, then it should be like.

grub2> (hd0,1)/efi/boot/grub OR (hd0,1)/efi/grub

(The location can be (hd0,2) or (hd0,3) depends on the partitions you have in your hard disk)

Once you get the grub location, try the following commands (Here, we assume the grub location as (hd0,1)/efi/boot/grub)

grub2> set prefix=(hd0,1)/efi/boot/grub
grub2> set root=(hd0,1)
grub2> insmod linux
grub2> insmod normal
grub2> normal

After this, you should be taken to the Ubuntu login page and system should boot fine. Then you can use https://help.ubuntu.com/community/Boot-Repair to repair your Ubuntu installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.