5

I ssh-connect an ubuntu server from an ubuntu client machine. And resume my screen session by running screen -d -r name. I'm not able to scroll inside the screen session. I created my screen session by running screen -S name. Do I have to pass any extra flag to make the scrolling work?

migrated from serverfault.com Jul 10 '18 at 2:49

This question came from our site for system and network administrators.

8

By default Screen will keep a scrollback buffer, but you can't use it the same way as the "conventional" scrollback buffer maintained by your terminal emulator. I.e. you can't use your mouse to scroll up.

You need use screen key bindings to enable copy/scrollback mode.

For me that is with CTRL+a ESC

(screen will notify that copy mode has been enabled)

and then I can use the UP-arrow on my keyboard to scroll back, but you can also use the other movement keybindings to move and select in the scrollback buffer.

  • 2
    Also while scrolling the first <ENTER> pressing begins the copy block and the second close the block and put it into the buffer. So pressing the <ENTER> twice quit the scrolling mode with the empty copy buffer. – Kondybas Jul 9 '18 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.