2

I'm running Arch Linux KDE. I would like SDDM to ignore certain users. However, even after adding the following config file, SDDM still displays all users. I tried both usernames and user ID's for the HideUsers parameters. Neither worked (all users were still displayed).

/etc/sddm.conf.d/uid.conf
[Users]
DefaultPath=/bin:/usr/bin:/usr/local/bin
HideShells=/sbin/nologin,/bin/false,/usr/bin/nologin,/usr/bin/git-shell
HideUsers=sue,sam,joe,jess
MaximumUid=1005
MinimumUid=1000
RememberLastSession=false
RememberLastUser=true

I also tried doing the config via KDE system settings GUI with no results. In all cases, all users are displayed regardless of any config changes I make. There are no other config files in /etc/sddm.conf.d/ and the main config (/etc/sddm.conf) does not have any conflicting settings. (In fact, I mirrored these settings in the main config and I tried this without any uid.conf at all, just using the main config. Again, all users are displayed regardless of any config changes.)

EDIT

As the config file shows, I have specified HideShells. As a temporary test, I also tried setting certain user accounts to have the /sbin/nologin in /etc/passwd, but even that did not prevent these user accounts from being displayed by SDDM. Crazy.

1

I found that SDDM has, by default apparently, another config file located at /usr/lib/sddm/sddm.conf.d/sddm.conf. After editing that file the same way I had previously edited /etc/sddm.conf.d/uid.conf, the issue is solved.

As an aside, unless someone knows otherwise, I consider this a bug. Config files in /usr/lib/ should not take precedence over config files in /etc/, right?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.