This is another one in a long line of problems of this sort.

After a recent upgrade from Fedora 27 to Fedora 28, broadcom-wl stopped working. The Broadcom adapter in question is an older BCM4312.

To get this adapter to work, I usually installed broadcom-wl, akmod, akmod-wl, and all dependency packages, including kernel headers, etc.

After running akmods --force or rebooting, things were usually fine...

This time however, not so. lsmod | grep wl reports the driver is loaded:

wl                   6463488  0
cfg80211              770048  1 wl

After running akmods --force I'm getting no errors, the driver supposedly loads fine with modprobe wl, too.

But, I still don't have a WiFi adapter visible with ip link show or iwconfig.

In my quest to solve the issue of not having WiFi, I've installed unitedrpms' repo and the broadcom-wl-dkms package from there.

Still, no cigar.

Not having WiFi on this laptop is most unpleasant, as being tethered to a router with a Cat5e cable is not really practical here for my application.

I've retraced all steps that got me WiFi with Fedoras up to this one. However right now, I'm somewhat at a loss, and I ask for further advice what to do now to get that adapter working again.

After loading wl with modprobe I'm getting this error with dmesg, which I believe is linked to my problem:

[22856.976760] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[22856.977471] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[22856.978252] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[22856.978257] cfg80211: failed to load regulatory.db
  • As it is, I didn't really have the chance to check if I can extract the firmware with b43-fwcutter from the original release. Instead, I just upgraded to Fedora 29 and the issue resolved itself automagically. For now, it seems things are working alright, but I guess this thread can be referenced should this arise anew. For now, I believe this question should be closed. – polemon Nov 17 '18 at 22:31

For my laptop the problem was secure boot, after marking secure boot as disabled in BIOS options the WiFi adapter is working.

I have broadcom-wl installed.

  • Hmm, I doubt this laptop even has that. But that aside, the laptop's WiFi did work fine before upgrading to Fedora 28. – polemon Sep 7 '18 at 20:40
  • Mine was the secure boot option, but was already disabled before. – cg. Sep 9 '18 at 10:31

I have the same issue with my computer as it uses Broadcom Wifi and Bluetooth.

I spent a long time trying to find a solution that worked consistently, and I came upon a post in fedoraforum.org, which has worked perfectly ever since. I would suggest you give it a try:


Go to the above link, and scroll to the post by gob17. Follow the instructions, and hopefully you should be up and running!

Let me know if it works for you...

  • Doesn't work, also, it's the standard instructions to install broacom-wl akmods, which I've explained in my question, didn't work. – polemon Sep 7 '18 at 20:33
  • It is basically yes. However, there is a section that mentions about a potential mismatch between system and uname kernel devels being used, which was a problem for me originally too. I have since written up the info in the link into a blog post if that is of any help? see here: thetestspecimen.com/broadcom-wifi-modules-fedora I should also point out that I also tried with broadcom-wl-dkms and had no luck with it. – TheTestSpecimen Sep 8 '18 at 21:58
  • Your instructions are exactly what I did on FC26 and it worked then. With FC28 it simply does not. Also, with a kernel version mismatch I am pretty sure the wl module would not load. Our problem is it does load and lspci is showing the adapter properly. But the rest of the wifi stack still won't recognise it. – cg. Sep 9 '18 at 10:37
  • Understood. Sorry I couldn't help. I have had other problems with F28 that I didn't have on F27. Every reboot took 10-15mins (literally). Turns out it was a kernel bug. I only managed to get around it with a clean install. – TheTestSpecimen Sep 9 '18 at 16:17

As stated in the comments above, I had the same or a very similar issue. For me, it turned out that the issue is described in Red Hat Bugzilla Bug 1572349. For some reason, "ssb" is no longer configured as a module in newer Red Hat kernels. This conflicts with loading the "wl" driver.

I was able to resolve it by removing the old broadcom-wl driver and manually installing the firmware for the b43 driver as described here:

  • Remove broadcom-wl and dependencies: dnf remove broadcom-wl
  • dnf install b43-fwcutter
  • Install Broadcom firmware as described here
  • Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.