0
smbclient //ERERYMJF/pwiwerp_Informatica -U 'PWI.kpp.com\a121212'

Above command was working fine before and not working on RHEL7. I am getting below error.

SPNEGO(gse_krb5) NEG_TOKEN_INIT failed: NT_STATUS_NO_MEMORY
session setup failed: NT_STATUS_NO_MEMORY

samba.conf

[global]
        client use spnego = no
        client ntlmv2 auth = yes

        workgroup = SAMBA
        security = user

        passdb backend = tdbsam

        printing = cups
        printcap name = cups
        load printers = yes
        cups options = raw



[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes

[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @printadmin root
        force group = @printadmin
        create mask = 0664
        directory mask = 0775

We are using Version 4.7.1.

  • I suspect this may be an SMB v1 vs SMB v2/v3 issue. Does the server ERERYMJF support SMB v2/v3? (If not, why not? SMB v1 is obsolete.) – roaima Jul 7 '18 at 12:13
  • I just have file system access to the remote windows server. Is there a way to get SMB version of remote host? – Koshur Jul 8 '18 at 11:45
  • I used the completed name of the sever - ERERYMJF - i.e. ERERYMJF.xyz.com and it worked! – Koshur Jul 8 '18 at 17:55
1

I used completed name of the server - ERERYMJF - i.e. ERERYMJF.xyz.com and it worked!

smbclient //**ERERYMJF.xyz.com**/pwiwerp_Informatica -U 'PWI.kpp.com\a121212'

As @roaima mentioned it is not a good solution and throws away the security around samba. However, this seems to be the only solution working for me as off now.

0

I found this AU Q&A titled: Ubuntu 17.10 to access Windows Files Shares within workplace IT

SPNEGO(gse_krb5) NEG_TOKEN_INIT failed: NT_STATUS_NO_MEMORY
session setup failed: NT_STATUS_NO_MEMORY

A workaround was shown that may work for you as well:

$ cat /etc/samba/smb.conf
...
client use spnego = no
client ntlmv2 auth = no
workgroup = WINWIRKGRP
...
  • I tried this. Did not work.. – Koshur Jul 8 '18 at 7:29
  • 1
    I fixed it with a minor change. I used the completed name of the sever - ERERYMJF - i.e. ERERYMJF.xyz.com and it worked! – Koshur Jul 8 '18 at 17:55
  • @Koshur - that terrific, be sure to mark your answer as accepted so others know it's resolved. – slm Jul 8 '18 at 18:06
  • This is a really bad solution. What you're doing is telling Samba to throw away much of the security wrapping and revert to really obsolete authentication. – roaima Jul 8 '18 at 19:17
  • @roaima - agreed and understood. It's what's also shown in many of the upstream bugs raised against these types of issues, so it seems the only options for these issues ATM. – slm Jul 8 '18 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.