1

I run a MUD in C and I'm trying to compile it on a newer version of CentOS (7):

sql.h:1:25: fatal error: mysql/mysql.h: No such file or directory

So I try to install the MySQL packages

[user@server src]$ sudo yum install mysql++-devel

But I get many conflict errors:

Resolving Dependencies
--> Running transaction check
---> Package mysql++-devel.x86_64 0:3.1.0-12.el7 will be installed
--> Processing Dependency: mysql-devel(x86-64) for package: mysql++-devel-3.1.0-12.el7.x86_64
--> Running transaction check
---> Package mariadb101u-devel.x86_64 1:10.1.32-1.ius.centos7 will be installed
--> Processing Dependency: mariadb101u-libs(x86-64) = 1:10.1.32-1.ius.centos7 for package: 1:mariadb101u-devel-10.1.32-1.ius.centos7.x86_64
--> Processing Dependency: pkgconfig(openssl) for package: 1:mariadb101u-devel-10.1.32-1.ius.centos7.x86_64
--> Running transaction check
---> Package mariadb101u-libs.x86_64 1:10.1.32-1.ius.centos7 will be installed
--> Processing Dependency: mariadb101u-common(x86-64) = 1:10.1.32-1.ius.centos7 for package: 1:mariadb101u-libs-10.1.32-1.ius.centos7.x86_64
---> Package openssl-devel.x86_64 1:1.0.2k-12.el7 will be installed
--> Processing Dependency: zlib-devel(x86-64) for package: 1:openssl-devel-1.0.2k-12.el7.x86_64
--> Processing Dependency: krb5-devel(x86-64) for package: 1:openssl-devel-1.0.2k-12.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-19.el7 will be installed
--> Processing Dependency: libkadm5(x86-64) = 1.15.1-19.el7 for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.15.1-19.el7.x86_64
---> Package mariadb101u-common.x86_64 1:10.1.32-1.ius.centos7 will be installed
--> Processing Dependency: mariadb101u-config(x86-64) = 1:10.1.32-1.ius.centos7 for package: 1:mariadb101u-common-10.1.32-1.ius.centos7.x86_64
---> Package zlib-devel.x86_64 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package libcom_err-devel.x86_64 0:1.42.9-12.el7_5 will be installed
---> Package libkadm5.x86_64 0:1.15.1-19.el7 will be installed
---> Package libselinux-devel.x86_64 0:2.5-12.el7 will be installed
--> Processing Dependency: libsepol-devel(x86-64) >= 2.5-6 for package: libselinux-devel-2.5-12.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.5-12.el7.x86_64
--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.5-12.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
---> Package mariadb101u-config.x86_64 1:10.1.32-1.ius.centos7 will be installed
--> Running transaction check
---> Package libsepol-devel.x86_64 0:2.5-8.1.el7 will be installed
---> Package pcre-devel.x86_64 0:8.32-17.el7 will be installed
--> Processing Conflict: 1:mariadb101u-config-10.1.32-1.ius.centos7.x86_64 conflicts mariadb-libs < 1:10.1.32-1.ius.centos7
--> Processing Conflict: 1:mariadb101u-common-10.1.32-1.ius.centos7.x86_64 conflicts mariadb-libs < 1:10.1.32-1.ius.centos7
--> Processing Conflict: 1:mariadb101u-libs-10.1.32-1.ius.centos7.x86_64 conflicts mariadb-libs < 1:10.1.32-1.ius.centos7
--> Finished Dependency Resolution
Error: mariadb101u-common conflicts with 1:mariadb-libs-5.5.56-2.el7.x86_64
Error: mariadb101u-config conflicts with 1:mariadb-libs-5.5.56-2.el7.x86_64
Error: mariadb101u-libs conflicts with 1:mariadb-libs-5.5.56-2.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Should I skip-broken or is there a better way to ensure I have the mysql C header files?

  • Is there a mariadb-devel? Have you tried yum whatprovides '*/mysql/mysql.h' to see what other packages provide this? – muru Jul 6 '18 at 5:00
  • This looks like you have mixed repos for your MariaDB packages. – slm Jul 6 '18 at 5:02
1

If you look through the MariaDB website, there's a FAQ that shows how to resolve the issue(s) you're running into. As I suspected, you've got a mishmash of RPMs installed that are not compatible with each other.

The FAQ is titled: MariaDB Installation (Version 10.1.21) via RPMs on CentOS 7

  • Helped me to install "KDE Plasma Workspace". Thanks! :) – jwanglof Aug 18 '18 at 9:07
  • What if rpm -qa | grep mariadb-libs yields nothing? – User Nov 24 '19 at 3:31
  • @User means it's not installed – slm Nov 25 '19 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.