1

I was on Linux Mint, now I'm trying Ubuntu 18 main distro. At top of Gnome day of week/time is displayed. That's where I started, wanting to change it to English having set regional to Russian via GUI, as by the way I noticed time zone changes if I changed regional to US. I've read and tried this: https://askubuntu.com/questions/754345/how-to-get-current-or-set-wanted-regional-format-in-the-terminal/754355#754355

Strangely, after sudo update-locale LC_TIME=en_CA.UTF-8 and even restart of PC, /etc/default/locale has CA, but locale in bash gives RU. And day of week on top of screen is in Russian still. Why different in file and by command? How to change language on top of screen, is it some short date variable, where to find it?

As extension to above, is it possible and how to change decimal point and thousand separator each individually to what I like?

0

As for message on top of screen, below are steps, for example for Russian Federation:

1) edit /usr/share/i18n/locales/ru_RU (e.g. by sudo nautilus)

change abday line to

abday "Sun";"Mon";"Tue";"Wed";"Thu";"Fri";"Sat"

2) bash $ sudo locale-gen ru_RU.UTF-8

3) set format in settings to Russian Federation (here first I wanted to make my own locale, but could not find how to make new territory so it appears in list in settings, e.g. in /usr/share/i18n/locales/ru_RU territory "Russia", but settings say Russian Federation - please somebody edit or comment how it can be done)

4) re-login

For decimal I changed it in /usr/share/i18n/locales/ru_RU, it is seen correctly in Ubuntu format settings, however does not work in LibreOffice calc for unknown to me reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.