0

I noticed whenever I restarted transmission-daemon on my machine I saw this:

 Warning: transmission-daemon.service changed on disk. Run 'systemctl daemon-reload' to reload units.

I run the command and check it with

 sudo systemctl status transmission-daemon

This is the result:

● transmission-daemon.service - Transmission BitTorrent Daemon
   Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/transmission-daemon.service.d
           └─local.conf
   Active: active (running) since Tue 2018-07-03 16:32:18 EDT; 13s ago
 Main PID: 662 (transmission-da)
   Status: "Uploading 2.73 KBps, Downloading 1.39 KBps."
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/transmission-daemon.service
           └─662 /usr/bin/transmission-daemon -f --log-error -g /etc/transmission-daemon

And the warning is gone. However, if I restart the machine the warning returns when I check the status again.

Why would the transmission-daemon.service file be changing?

When I run ls -la I get this back in the last modified date:

$ la /lib/systemd/system/transmission-daemon.service                                                                        
-rw-r--r-- 1 root root 284 Jan 12 02:00 /lib/systemd/system/transmission-daemon.service

And Jan 12 was six months ago, so it appears it hasn't changed.

What can I do to get rid of the warning? (I'm troubleshooting some mysterious non-responsiveness and want to rule this out)

Am I asking the right questions? Is there something else I should be doing?

I'm running ARMBIAN 5.35 Stretch on a BananaPi Pro.

Thanks!

  • 1
    I notice systemctl is loading /etc/systemd/system/transmission-daemon.service.d/local.conf in addition to /lib/systemd/system/transmission-daemon.service. Anything interesting in that local.conf file? Has that file registered any recent changes? – GracefulRestart Jul 3 '18 at 20:59
  • Hi @GracefulRestart Gave it a look. local.conf was last modified on April 13. It's contents are: [Service] ExecStart= ExecStart=/usr/bin/transmission-daemon -f --log-error -g /etc/transmission-daemon Any thoughts? – SteveLambert Jul 3 '18 at 21:10
  • Nothing that I see in the output would cause the behavior you are describing. I did a quick search, and found a systemd bug similar to what you describe that looks like the fix would have been released with systemd-230. If your systemd is older then that, that could be the issue. If not, I am out of ideas. – GracefulRestart Jul 3 '18 at 22:06
  • Hmm... systemd --v gives me systemd 232 Thanks for trying! – SteveLambert Jul 3 '18 at 22:26
  • Do you have a systemd generator that may touch this file? – Patrick Mevzek Jul 3 '18 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.