I have a dz77ga-70k motherboard with version 0049 of the Intel firmware on it. Linux and elilo will not boot in uefi mode. The symptoms are that when I run bzImage.efi initrd=initrd.img ro debug loglevel=8 earlyprinkt=vga root=/dev/sda2 from the uefi shell, it hangs. And elilo will reboot after selecting the kernel.

Then I compiled the latest kernel source and that failed too. I have added some debugging output to the source, specifically arch/x86/boot/compressed/eboot.c and what seems to be happening is that the call to exit_boot_services is failing all the time. This also happens with elilo.

From the uefi spec, the only reason that exit_boot_services should fail is because the memory map has "changed" between get_memory_map and exit_boot_services.

I'm usually a graphics programmer and don't know much about the kernel/bios stuff, so how can I tell if this is a bug with the firmware or the kernel? I don't mind doing some testing.

It seems that other people are having a similar problem with a similar motherboard: http://comments.gmane.org/gmane.linux.redhat.fedora.devel/167170

Looking at the 8 segment led status codes on the mb, it goes C6 -> start kernel -> F8 -> B1 then hangs. F8 is ExitBootServices and B0 to BF is "detecting and initing fixed media" so maybe it is getting past ExitBootServices?

Any clues?

  • Try another bootloader, I had some issue a few months ago (using grub legacy) - as soon as I used syslinux it worked fine, though I must admit I have no clue why (GA-Z77X-D3H in my case in EFI mode). – drahnr Aug 30 '12 at 10:56
  • According to here syslinux does not support uefi booting at the moment, only bios. I think my title may have been misleading, I am trying to boot in uefi mode, bios mode works. – ashleysmithgpu Aug 30 '12 at 13:50
  • The BIOS/EFI "thing" said it would boot in efi mode, though I can not say if it had an autofallback to BIOS in case efi failed. Sorry for the noise. – drahnr Aug 30 '12 at 18:53

Apparently it was a bug with the UEFI firmware, as described in the release notes for intels 0053 firmware update. However DO NOT install it. It will brick your motherboard! Well done intel. Yet another reason not to have UEFI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.