2

I'm currently using the Adapta-Nokto theme on Linux Mint 18.2 Cinnamon. When using any dark theme (specifically the Controls portion of it), some web inputs (presumably those with some form of background-color attribute missing) default to the background color used by input fields in the system. This would be fine, if not for them still retaining the black text color. This makes things very difficult to see when doing any form of input. See below (the Dropbox search bar):

dark dropbox text input

Is there even a fix for this? I've noticed it when I first installed Mint and used one of the default dark themes too, so as I mentioned this is apparent for any dark theme.

1

A fairly decent fix for this is overriding the styles in ~/.mozilla/firefox/{userprofile}/chrome/userContent.css.

I found this fellow's instructional video to get me started and then made some minor edits from there. https://www.youtube.com/watch?v=2a7rgRsO6q4

My edits were flipping the black and white as well as adding !important to the color and background-color attribs. Some websites styles were overriding the text color I had set and I like white text on black background.

pastebin for css from linked video: https://pastebin.com/My5byv4j

This fix is not perfect, but I found it to be better than without it.

Edit: A warning. Last night I found out the hard way that some radio buttons are not visible with these css overrides in place. The problem may simply be due to my edits to the linked css, I'm not sure yet.

  • 1
    Thanks, this seems to work so far! Haven't tested it with everything of course, but as you say it is better than without it. – TheCapeGreek Aug 9 '18 at 7:37
  • Nice! Glad it helped and glad you asked the question. A while back, I tried to fix the problem to no avail. Then tried living with it until yesterday. Your question pointed out that the problem seems to be only in the browser... that made it a lot easier to hunt for a fix. – zerpsed Aug 9 '18 at 12:51
1

Following on from @zerpsed answer - to avoid any unforeseen issues resulting CSS/file from customisation...

You can just force FireFox (63.0.3 (64-bit) on Linux Min 19 in my case) to use a non-dark theme for site inputs.

  1. Head to Firefox's "secret" settings by typing in about:config into the URL bar.
  2. Search for widget.content.gtk-theme-override.
  3. Double click its value column to enter a non-dark theme such as 'Adwaita' (which is already shipped with LinxMint).
  4. Then close all Firefox windows and open again.
  5. Fixed - you'll notice the window borders are still dark but form inputs etc are forced to use the light theme fixing the issue with no bugs resulting from customisation that I've found.

Found via Linux Mint forums, specifically point 2 of this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.