4

I am trying to add the intel products repository to dnf by creating a .repo file but when I run dnf repolist I am getting this error:

Failed to synchronize cache for repo 'intel-products', disabling.

My intel-products.repo file in /etc/yum.repos.d looks like this:

[intel-products]
name=intel-products
baseurl=https://yum.repos.intel.com/setup/intelproducts.repo
enabled=1
gpgcheck=1
gpgkey=https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB

What is wrong with this file?

Update 1

As suggested in comments, I tried running dnf repolist --verbose which shows:

Cannot download 'https://yum.repos.intel.com/setup/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried.

After changing the baseurl variable to the full path of the url, I get the same:

Cannot download 'https://yum.repos.intel.com/setup/intelproducts.repo': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors w
ere tried

Update 2:

Output of curl https://yum.repos.intel.com/setup/intelproducts.repo:

[intel-ipp-repo]
name=Intel(R) Integrated Performance Primitives
baseurl=https://yum.repos.intel.com/ipp
enabled=1
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB

[intel-mkl-repo]
name=Intel(R) Math Kernel Library
baseurl=https://yum.repos.intel.com/mkl
enabled=1
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB

[intel-tbb-repo]
name=Intel(R) Threading Building Blocks
baseurl=https://yum.repos.intel.com/tbb
enabled=1
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB

[intel-mpi-repo]
name=Intel(R) MPI Library
baseurl=https://yum.repos.intel.com/mpi
enabled=1
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://yum.repos.intel.com/intel-gpg-keys/GPG-PUB-KEY-INTEL-SW-PRODUCTS-2019.PUB
  • Can you try dnf repolist -v ? – Ortomala Lokni Jul 2 '18 at 15:17
  • @Ortomala Lokni I have updated the post with the output of dnf repolist -v – MyWrathAcademia Jul 2 '18 at 15:23
  • What's the result of curl https://yum.repos.intel.com/setup/intelproducts.repo ? – Ortomala Lokni Jul 2 '18 at 15:47
  • @Ortomala Lokni good idea curls output provides very good information – MyWrathAcademia Jul 2 '18 at 16:04
  • @Ortomala Lokni I changed the url to baseurl=https://yum.repos.intel.com/ but I'm still getting the same error. – MyWrathAcademia Jul 2 '18 at 16:25
2

Your baseurl is incorrect, it should be pointing to a repository with a repomd.xml and not a .repo file.

Try:

curl https://yum.repos.intel.com/setup/intelproducts.repo > /etc/yum.repos.d/intel-products.repo; dnf repolist

and see if that works any better

0

I needed to use exactly the same .repo files created by intel since I didn't know how they defined the variables and values in their file. For this, I used the output of curl to standard output:

curl https://yum.repos.intel.com/setup/intelproducts.repo | cat > intel-products.repo

  • Did you just copy the answer someone else gave you and accept your own instead of theirs? – Centimane Jul 6 '18 at 18:15
  • Of course not, I solved this a long time ago and moved on to something else. Just got round to posting my answer. The only help I got was from @Ortomala Lokni whose comments allowed me to pin-point a solution. – MyWrathAcademia Jul 6 '18 at 18:19
  • 1
    You say a long time ago, but this was asked 5 days ago, and the answer is from the same day you asked. I'd say it would be better to accept the answer already written if it's correct rather than re-writing it. – Centimane Jul 6 '18 at 18:21
  • Save yourself some typing. curl -O https://yum.repos.intel.com/setup/intelproducts.repo achieves same thing. – steve Jul 6 '18 at 18:37
  • @steve I don't think that will work, I'm pretty sure I tried that already thats why I decided to use the redirect operator instead. – MyWrathAcademia Jul 6 '18 at 18:41
0

curl -O ought to do the trick on Fedora. Certainly does here, on CentOS 7.

# cd /etc/yum.repos.d
# ls i*
ls: cannot access i*: No such file or directory
# curl -O https://yum.repos.intel.com/setup/intelproducts.repo
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1362  100  1362    0     0   3150      0 --:--:-- --:--:-- --:--:--  3145
# ls i*
intelproducts.repo
#
  • it downloads but have you tried to access that repo through dnf, in your case yum since you're on CentOS? – MyWrathAcademia Jul 6 '18 at 19:12
  • Yes. Yum repolist etc all imported new keys and connected to Intel repo fine – steve Jul 6 '18 at 19:13
  • In that case that's actually a good alternative, that means wget can also get the job done as well. Can you explain why you are using ls -i rather than ls. Isn't the -i option for inode? – MyWrathAcademia Jul 6 '18 at 19:22
  • Just ls i* to list all files that start with "i". So confirming that the intelproducts.repo file does not initially exist. And that after the curl invocation it does happily exist. – steve Jul 6 '18 at 19:33
  • Ahh I see, you were using a wildcard, I mistook it for the -i option. – MyWrathAcademia Jul 7 '18 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.