3

When I enter, for instance, xdg-mime query filetype Video/movie.mkv, the output is video/x-matroska; if I then enter xdg-mime query default video/x-matroska, the output is mplayer.desktop, and that is indeed the application used when I enter xdg-open Video/movie.mkv. The same holds for other filetypes for which I've set specific default applications.

On the other hand, nothing happens when I click on "Open Dropbox Folder" in Dropbox' tray icon popup menu, or when I do right-click and "Open folder" on a file in Transmission's list of downloaded files; so, I would expect that no application is associated with directories.

With this in mind, what I've tried so far is to run xdg-mime query filetype Video, which returns inode/directory and, in turn, run xdg-mime query default inode/directory, which returns ranger.desktop, my file manager. This sounds quite what I would have expected if everything worked, but this is not the case.

Why nothing happens when I click on "open folder" et similia in popup menus?

1 Answer 1

1

I assume your ranger.desktop file looks like this:

[Desktop Entry]
Type=Application
Name=ranger
Comment=Launches the ranger file manager
Icon=utilities-terminal
Terminal=true
Exec=ranger
Categories=ConsoleOnly;System;FileTools;FileManager
MimeType=inode/directory;

ranger is a terminal application, you have to run e.g. xterm -e ranger. You can see what is happening, when you use i3menu and type ranger or xterm -e ranger.

There is the line Terminal=true which has this effect but you probably miss the configured terminal application.

Actually it seems Terminal=true is somehow not working as expected. But @Hanlon documented a workaround at superuser.com.

4
  • Where should I find this default desktop file? By i3menu are you referring to any program I use to run applications or to a specific one?
    – Enlico
    Jul 2, 2018 at 10:22
  • 1
    You can list all files of a package with: pacman -Ql ranger. Use $mod+d to test the commands: wiki.archlinux.org/index.php/i3#Application_launcher
    – ctx
    Jul 2, 2018 at 10:34
  • (Thank you for the pacman tip!) Well, I don't use dmenu, but rofi in its place, but I think it's same, isn't it? Indeed, when I run xterm -e ranger (actually urxvt) from inside rofi, ranger correctly opens.
    – Enlico
    Jul 2, 2018 at 10:47
  • 1
    I could not find the correct way to use urxvt with xdg-terminal. It seems that Trilby and Progandy did not find it too: bbs.archlinux.org/viewtopic.php?id=232051
    – ctx
    Jul 2, 2018 at 11:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .