1

I’ve just installed i3 and after using it for around 10 minutes (and not being able to open anything using dmenu — nothing loaded), I tried going back to MATE. I’m running Mint 18.2 Sonya.

I get the following errors:

initctl: Unable to connect to Upstart: failed to connect to socket /com/ubuntu/upstart: Connection refused

/etc/mdm/Xsession: Beginning session setup...

/etc/mdm/Xsession: 27: /home/bthalenberg/.profile: [[:  not found

localuser:bthalenberg being added to access control list

Everything seems to work from tty, I even tried removing i3 but it did not fix the issue. I’m posting from my phone, sorry for the crappy formatting

  • Fixing your .profile to run without error on /bin/sh, which on Debian and derivatives such as Mint is not bash, will either work or get you a more useful error message. Single [ is a command, double [[ is a bash extension – Fox Jul 2 '18 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.