1

I recently purchased this USB wireless network adapter for my old desktop but have been unable to get the wireless drivers to work on any distro I've tried. I've tried Robolinux, Fedora, and a few others that I can't remember the names of. It came with a CD that only has Windows drivers on it. Of course I've tried using the Windows Wireless Drivers utility to install the Windows drivers on Linux but it always says that it's an invalid driver.

I can't download drivers through terminal since I have no network connection without the drivers.

In Windows device manager it appears as "Realtek 8812BU Wireless LAN 802.11ac USB NIC".

closed as too broad by Rui F Ribeiro, schily, slm Jul 2 '18 at 3:12

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try this driver: github.com/jeremyb31/rtl8822bu – Ipor Sircer Jul 1 '18 at 15:46
  • @lporSircer Thank you for the link. I get an error when I try to build with the makefile though: install: cannot stat '8822bu.ko: No such file or directory. And when I try just typing "make" it says make[1]: *** /lib/modules/4.16.3-301.fc28.i686/build: No such file or directory.` – Christopher Russell Jul 1 '18 at 16:44
  • The question would benefit from being shorter, and identifying the wifi hw id, and laptop manufacturer. some ac chipsets are often not yet well supported, USB wifi chipsets do not perform as well as internal, and RealTek churns out a lot of buggy stuff, where especially the power saving features do not work. – Rui F Ribeiro Jul 1 '18 at 17:00
  • I'm not sure what the wifi hw id is but I had my friend try to build this on his ubuntu installation and he encountered a similar error. The desktop is a dell vostro 220. Is there something I need to install beforehand for this to work? – Christopher Russell Jul 1 '18 at 17:07
  • I'm not sure how this is too broad. I just need a link to a driver that works for the 8812BU on Linux. The few I've tried have not been able to build successfully. – Christopher Russell Jul 2 '18 at 23:34