0

This question already has an answer here:

Please take care that you have no unsaved work if you test this.

I ran this command as an experiment, but how can I undo it without rebooting?

# mount --rbind / /mnt

What I have tried

  1. # umount /mnt
    umount: /mnt: target is busy.
    
  2. # strace -f -e umount,umount2 umount -R /mnt
    umount2("/mnt/var/lib/nfs/rpc_pipefs", 0) = 0
    umount2("/mnt/sys/kernel/security", 0)  = 0
    umount2("/mnt/sys/fs/cgroup/unified", 0) = -1 EBUSY (Device or resource busy)
    umount: /mnt/sys/fs/cgroup/unified: target is busy.
    +++ exited with 32 +++
    
  3. # umount -l /mnt
    # findmnt
    findmnt: can't read /proc/mounts: No such file or directory
    

    (this is the catastrophe I warned you about).

Environment

Fedora 28.

marked as duplicate by sourcejedi, Community Jun 30 '18 at 9:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You need to run mount --make-rprivate /mnt before you can safely unmount it. See the question Mounting new filesystem affects non-recursive bind mounts?

I thought I had tried this, but something went wrong. Maybe I had missed the r off --make-rprivate.

Not the answer you're looking for? Browse other questions tagged or ask your own question.