2

I have Antergos/Arch. Some months ago I upgraded chromium using Pacman in a routine system upgrade. After the upgrade chromium wouldn't start and it'd throw me a Segmentation fault (core dumped) error.

I assumed it was just a bug that would eventually get fixed, so I downgraded to my previous version (65.0.3325.181-5) and forgot about it until today. Today I tried upgrading Chromium again to the most recent version (67.0.3396.87-2) only to find out that I still get the some error. So I think it's unlikely that this is a bug from chromium.

For the time being I have no idea what's causing this and I have no idea how to investigate this problem. I'm using a Samsung np900 and, besides this issue, I've had never any problems with my installation. (Chrome, by the way, works just fine.)

Any ideas as to what's going on?

  • Works fine for me. Have you deleted/moved your profile and restarted? If that doesn't work, you'll need more intensive debugging. – jasonwryan Jun 30 '18 at 4:57
  • @jasonwryan I have removed my ~/.config/chromium and upgraded, with the same result. I'm not sure where exactly my profile is stored, but afaik it should be all contained in that directory, right? Any suggestions? – TomCho Jun 30 '18 at 6:01
  • Yes. You'll need to move to gdb. – jasonwryan Jun 30 '18 at 6:04
  • On Mint/Ubuntu I noticed that the code requires a more recent version of libnss3 but the deb file wasn't set up to include that as a dependency, so it wasn't auto installed by apt. Possibly similar situation? Check ldd /path/to/chromium-binary to make sure all libraries are being found, etc. – ivanivan Jun 30 '18 at 14:09
  • @jasonwryan thanks for the tip. Based on that I actually found I just had to delete ~/.config/chromium-flags.conf. It was pointing to a directory in /home/antergos that was remnant from the liveUSB installation for some reason. – TomCho Jun 30 '18 at 15:11
1

Posting the answer for completeness. The issue was that ~/.config/chromium-flags.conf was pointing to a directory in /home/antergos/ instead of my user's home directory. This was apparently a bug reported by more people but that is now fixed. I just had to delete this file since it is not used anymore.

  • I've been facing the same problem for about the same time. This worked for me. Thanks for posting the solution. :) – Indradhanush Gupta Jul 6 '18 at 7:59
  • @IndradhanushGupta glad to help, my man – TomCho Jul 14 '18 at 5:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.