2

I'm running Ubuntu 18.04 on an MSI GE63 Stealth 8RE, with an NVIDIA GTX 1060. There's a good amount of screen tearing when watching videos, and I found several sources online telling me that creating a file in /etc/modprobe.d/ with options nvidia_drm modeset=1 would resolve the issue.

Lo and behold, it did! No more screen tearing! It fixed the Prime Synchronization issues. However, for some reason, I was no longer able to connect to my HDMI monitor. The output of xrandr --query is as follows:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP-1-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.02*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)

I'd like to not have screen tearing, but I'd also like to be able to use my HDMI port. Does anyone have a suggestion as to what I can do to resolve this issue?

  • With My Ubuntu - And I was the one who started the thread for "4 Easy Steps to Stop Screen Tearing" – markackerman8-gmail.com Nov 16 '18 at 18:14
0

With My Ubuntu - And I was the one who started the thread for "4 Easy Steps to Stop Screen Tearing"

My Nvidia 410 has an option for VSync On ... and it says it IS ON!!! and though My tried and true command to see if it is on says it IS NOT ON!

sudo cat /sys/module/nvidia_drm/parameters/modeset

Perhaps Nvidia's Linux Driver 410 is getting Better! GTX 1080M for reference!

0

The reason most likely is because when you pass over control to the NVIDIA card, the HDMI port needs to be connected to that card. What I would suggest is checking out the package intel-virtual-output.

This package sort of "jolts" your graphics card awake so that it can connect to all video/HDMI/DP ports, then extends the current desktop to two more virtual screens. Your outputs should be running smoothly off of the NVIDIA card.

0

I fixed the issue!! I switched from using GDM3 to LightDM, rebooted, and I no longer have the issue of not being able to connect to external monitors. I tested on both DisplayPort and HDMI external monitors. It also happened to fix a problem I'd been having with external monitors not being recognized as viable audio sinks, so now I also get audio out of my external monitors, with no screen tearing :)

To switch from GDM3 (which is the default display manager since Ubuntu 17.10) to LightDM, I just ran sudo apt install lightdm because it wasn't already installed, and it prompted me with the option to choose which display manager to have as my default.

If you already have it installed, running sudo dpkg-reconfigure gdm3 will show you the same prompt.

I hope this helps anyone else who runs into this issue :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.