14

I'm a big fan of Terminator. By default, the preferences menu is accessible by a right click on the terminal. I just configured Terminator to do a copy paste on right click (similar like Putty).

Unfortunately, that makes the preferences menu is not accessible anymore. What is the solution?

4
  • 4
    Check please if this menu will be accessible by pressing Shift + F10 keys. – mariaczi Jun 29 '18 at 8:30
  • Ahh yep that solves my problem. Thank you :) – anta40 Jun 29 '18 at 9:18
  • 1
    Middle click in Terminator works like right one in Putty You may want to not redefine )) – Tagwint Jun 29 '18 at 11:15
  • Excellent answer to another question: "Where in the world do you find the Preferences menu?!" :) – David Parks Jul 18 '18 at 21:46
21

It's the (awkward) shift+middle-click combo that brings up Terminator context menu for me when putty_paste_style = True.

This is in contrast to the docs, both the terminator_config manpage and the online manual, which state middle-click alone will bring up the Context Menu.

$ terminator --version
terminator 1.91

$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"

The mentioned shift+F10 combo also works, but also stuffs garbage (;2~) onto the command line.

2

The middle-click on the mouse does, indeed, work and can bring up the context menu. However, what is probably missing from the manual is the fact that it requires a DOUBLE click of the middle mouse button (basically your scroll wheel).

Here are the exact instructions:

  1. Open/Start Terminator.
  2. Place your mouse pointer anywhere (e.g. the middle) within the open Terminator window.
  3. Double click the middle mouse button (scroll wheel).
  4. Select "Preferences" from the drop-down that pops up on the screen.
2

I'm running Linux Mint 19.2 and I was on a laptop with only a track-pad (thus no middle click), so to fix this I editing ~/.config/terminator/config. Just find putty_paste_style and make it equal "False". Save the file and restart terminator.

$ vim ~/.config/terminator/config
...
[global_config]
  putty_paste_style = True  ##<<< change this to "False"
[keybindings]
[layouts]
  [[default]]
    [[[child1]]]
      parent = window0
      type = Terminal
    [[[window0]]]
      parent = ""
      type = Window
[plugins]
[profiles]
  [[default]]
    background_darkness = 0.75
    background_type = transparent
    copy_on_selection = True
    cursor_color = "#aaaaaa"
    scroll_on_keystroke = False
    scrollback_infinite = True
1
  • 1
    I wish we could shift + right click to show the context menu or paste. – Pluto May 18 '20 at 0:03
0

While middle click and editing the terminator config file may work, you can also delete the entire config file by running:

sudo rm -rf ~/.config/terminator

This deletes ALL of your preferences. Terminator generates a new preference file when it relaunches. Worked fine in my case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.