1

My bridge device is set up on the 192.168.1.0/24 network, and my KVM devices are set up on a virtual network (NAT to br0) in the 192.168.100.0/24 network. I have a MAAS server in KVM at 192.168.100.10 which provides DNS services for all my KVM guests. I am trying to ssh to these guests using their hostname, but it is not working.

/etc/conf.d/net

# Set up the initial layer 2 bridge interface
bridge_br0="enp4s0"

# bridge
config_br0="dhcp"

bridge_forward_delay_br0=0
bridge_hello_time_br0=1000
dns_domain="maas"
dns_servers="192.168.1.1 192.168.100.10 8.8.8.8"
dhcp="nodns"

/etc/resolv.conf

# Generated by net-scripts for interface br0
domain maas
nameserver 192.168.1.1
nameserver 192.168.100.10
nameserver 8.8.8.8

Some Tests

damaya@data ~ $ ssh ubuntu@juju.maas
ssh: Could not resolve hostname juju.maas: Name or service not known
damaya@data ~ $ host juju.maas
Host juju.maas not found: 3(NXDOMAIN)
damaya@data ~ $ host juju.maas 192.168.100.10
Using domain server:
Name: 192.168.100.10
Address: 192.168.100.10#53
Aliases: 

juju.maas has address 192.168.100.178

My question: What network settings do I need in order to allow my host system to be able to use the DNS server provided by MAAS?

  • According to your resolv.conf, you're contacting 192.168.1.1 before the MAAS server. What's on 192.168.1.1? Also, does the MAAS server contain a recursing DNS resolver, or does it only return queries for the .maas domain? – ErikF Jun 29 '18 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.