1

I made a fresh install of Fedora 28 (kernel 4.17) on my Thinkpad P50 with NVidia Quadro M1000M. I have had trouble with external screen (did not work) so I decided to install proprietary NVidia drivers.

In the end I ended up with working environment once I set BIOS to use discrete graphics only (not hybrid), but after ~2 hours the system got stuck (when I tried to install xrandr to adjust brightness) and I hard-rebooted. Since then I can't login into Gnome; both screens turn black and I can only see the cursor. I have successfully installed Cinnamon and that works. However since I am more used to Gnome I'd prefer to be able to use it.

Reinstalling (dnf remove gdm && dnf install gdm) did not help. I have disabled Wayland in /etc/gdm/custom.conf but to no avail - I somehow even lost the 'Gnome Classic' option in the login screen.

I've tried to get back to Nouveau but I am stuck on laptop-screen only on 1024x768 - and the driver is not black-listed in any file in /etc/modprobe.d/. I have tried both 390 and 396 drivers (compiled myself) and 396 from negativo17, same result.

What configuration could get broken?

  • I think maybe we have the same issue. Can you try switching to non graphical mode (Ctrl + alt + F2) and then back to graphical mode (Ctrl + Alt + F1)? On CentOS, this allows me to bypass this black screen. Does it help? – Kevin Lemaire Jun 29 '18 at 14:53
  • Regrettably not. From non-graphical mode I can only login & pkill gnome which gets be back to the login screen. – Radim Vansa Jun 29 '18 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.