0

It seems that an anaconda update has messed up my gfortran / MPI installation. I have tried reinstalling both gfortran and openmpi. Compilation of my code is successful, but on run time I get

mpirun: error while loading shared libraries: libmpl.so.1: cannot open shared object file: No such file or directory

There does not seem to be a package libmpl-dev according to apt-get. Although I believe that the problem could be resolved by changing some paths, perhaps it is simpler to just reinstall all the relevant components? Can anyone advise on how to do this properly? Basically, I do not want to use any libraries from anaconda (because things worked fine before installing it).

3
  • libmpich-dev... Commented Jun 28, 2018 at 14:06
  • @IporSircer This package is installed, but the problem remains. Commented Jun 28, 2018 at 14:10
  • Then fill a bugreport. Commented Jun 28, 2018 at 14:14

0

You must log in to answer this question.

Browse other questions tagged .