0

The automatically logged in user is the guest-session and the login script is run through /etc/guest-session/auto.sh. It produces no error message, just stalls on a black screen.

It is Linux Mint 18.3, cinnamon. 64-bit, it never gets to desktop anymore, I can't find the specific script since I can't access the computer, but it was meant to get idle time from xprintidle, then compare that to the variable I used to denote sleep time, exit gnome session if greater, sleep again if lower.

I have full root access, just not on the automatically logged in user that is the guest-session.
Tried solutions: Ctrl+alt+f1 changed nothing

  • Have you tried the standard Ctrl + Alt + F1 – roaima Jun 27 '18 at 6:49
  • If @roaima suggestion fails do you have SSH access? – eyoung100 Jun 27 '18 at 6:53
  • If you can't access it, who can? – muru Jun 27 '18 at 6:56
  • Mint should have virtual consoles, virtual ttys. Try pressing CTRL+ALT+F1 to Fn on your keyboard to reach them and log in text mode. – Mikhail Zakharov Jun 27 '18 at 7:40
0

Boot a live Linux (e.g. the Linux Mint installation from a USB thumbdrive), mount the root partition from the internal drive, find and fix/disable the bogus script.

1

First of all, you should log in into single user mode and remount required partitions with rw option.


Booting into single user mode

Interrupt boot process to access GRUB menu. In order to do that, press any key when 'Booting into .... in X' is shown.

Enter edit mode of your latest kernel (or the one that you're using as default) and edit line which starts with linux /boot/vm* <..> ro quiet splash and append init=/bin/bash to the end of it.

Press F10 to save and press b to boot with the new option.

This will boot you into root shell (you'll have no GUI there). Now remount root as writable filesystem.

mount -o rw,remount /


Eliminate the issue

Choose one:


+- Investigate the issue directly from single user mode.

Find the broken script in /etc/profile, /home/guest/.bashrc or any other configuration file which is sourced at the log in process.


+- Disable guest from auto logging in into the system by default.

Modify line autologin-user=user in /etc/lightdm/lightdm.confto be autologin-user=.


Resuming boot process

Remount root filesystem into ro mode with mount -o ro,remount /.

Execute /sbin/init to continue the boot process, or press CTRL+d to reboot the machine.


Depending on which path you took, you'll be able to log in either as guest (if stalling script was eliminated from auto execution on log in) or as your user with root privileges (if guest was excluded from autologin process).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.