0

When I try to import my music library in Rhythmbox, it doesn't recognize any of the files as music (all mp3). When I try to play one of the files directly, I get an import error in Rhythmbox that reads Problem occurred without error being set. This is a bug in Rhythmbox or GStreamer. I can play the files with another player like VLC or Videos.

I've already reinstalled Rhythmbox which didn't change anything, so I tried to reinstall GStreamer and I get the following error:

The following packages have unmet dependencies:
 gstreamer1.0-libav-dbg : Depends: gstreamer1.0-libav (= 1.14.1-1) but 1:1.10.4-dmo1 is to be installed
 gstreamer1.0-python3-dbg-plugin-loader : Conflicts: gstreamer1.0-python3-plugin-loader but 1.14.1-1 is to be installed
 gstreamer1.0-python3-plugin-loader : Conflicts: gstreamer1.0-python3-dbg-plugin-loader but 1.14.1-1 is to be installed
E: Unable to correct problems, you have held broken packages.

This seems strange to me, why is gstreamer1.0-libav 1.10.4-dmo1 going to be installed if a newer version is required?

I am running Debian testing with the unstable repository pinned at a lower priority and testing set as default.

  • Did you try the suggestions from askubuntu.com/questions/223237/… ? – Hermann Jun 26 '18 at 19:03
  • Thanks for the suggestion, I hadn't seen this. I have no held packages, I am using aptitude and unfortunately the -f flag results in the same output. – iuvbio Jun 26 '18 at 19:15
  • What happens if you request installation of the dependency while specifying the exact version with sudo apt-get install gstreamer1.0-libav=1.14.1-1? – Hermann Jun 26 '18 at 20:42
  • 1
    Usually you need the 'ugly' plugins for copyright encumbered MP3 etc. formats. See if the plugins are installed. – ajeh Jun 26 '18 at 20:48
  • @ajeh thanks, the ugly plugins are installed. @Hermann this I could install the correct version like this (it says downgraded so apparently 1:1.10.4-dmo1 is newer). However, when I try to reinstall gstreamer I still get the error for the two python plugins. There it doesn't give me an exact version that should be installed, do you know how to fix this? – iuvbio Jun 27 '18 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.