1

I put tilix -e nvim command for shortcut in my xfce. Then I do :!echo $PATH and doesn't get my regular $PATH value. The same for :echo $PATH. If I put command in whisker menu, I got the same.

But when I run it from my shell $PATH is loaded as expected.

How can I pass my .profile or .zshrc to tilix when run it through xfce shortcut or whisker menu?

0

I had similar issue (if I understand You correctly), when I tried to run NVM under Tilix. NVM's commands put in .profile file didn't made any effect in Tilix.

export NVM_DIR="$HOME/.nvm"
[ -s "$NVM_DIR/nvm.sh" ] && \. "$NVM_DIR/nvm.sh"  # This loads nvm
[ -s "$NVM_DIR/bash_completion" ] && \. "$NVM_DIR/bash_completion"  # This loads nvm bash_completion

I had to move these three lines into .bashrc...

1
  • I decided to switch to Arch :))
    – neochar
    Jul 16 '18 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.