0

MY school got donated 35 computers that are 4 years old. Each computer has 32 bit architecture. I've taken one to use it for and AR Sandbox (project by Oliver Kreylos). For that I've installed Linux Mint Version 18.3 "SYLVIA" with MATE desktop for 32 bit architecture. Then I have installed all software needed by the AR Sandbox, since now referred to as SARndbox. Then I got to the last step of this installation process, the ./bin/CalibrateProjector -s 1024 768 step. When I run that I get this error:

~/src/SARndbox-2.4 $ ./bin/CalibrateProjector -s 1024 768
CalibrateProjector: Capturing 120 background frames...Vrui: Caught exception GLExtensionManager: Extension GL_EXT_gpu_shader4 not supported by local OpenGL while initializing rendering windows
 done

which means I don't have drivers compatible with openGL which are necessary to run this program. I've installed the SARndbox in three different computers and this is the first time I got this error.

When I run lspci | grep VGA, I get 00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09).

Then glxinfo | grep Vendor gives me server glx vendor string: SGI client, glx vendor string: Mesa Project, and SGI OpenGL vendor string: Intel Open Source Technology Center which means I don't have the necessary drivers installed. I have started using Linux three months ago and I still don't know how exactly drivers work in Linux, I have read that normally Linux comes with all the necessary drivers out of the box but sometimes there are proprietary drivers which need to be installed from their site. And I have already searched for quite a while but I didn't find the drivers for Linux.

Could anyone tell me where to find them? I think I could install them by myself but if you will, could you explain me how to install them too? Thank you in advance.

  • Who told you it's a 32 bit CPU? When in doubt, go to Intel ARK, as in ark.intel.com/products/55452/… for instance, and scroll down to bitness - it reads 64 bit. You do not have to run 64 bit, but in general you should. – ajeh Jun 26 '18 at 14:57
0

Extension GL_EXT_gpu_shader4 not supported by local OpenGL while initializing rendering windows

doesn’t mean that you don’t have the appropriate OpenGL drivers, it means that the software you’re trying to run isn’t written correctly. It should either request GL_EXT_gpu_shader4 using a core profile (not a compatibility profile), or it should target OpenGL 3.0 or greater, which incorporate the features provided by gpu_shader4 as a core feature (no extension needed).

The “Intel Open Source Technology Center” vendor string means you do have OpenGL drivers running. glxinfo | grep version will tell you exactly what version of OpenGL your system supports.

Note that Xeon E3 systems are 64-bit systems, so unless you have a particular reason to run a 32-bit distribution, you should install the 64-bit version instead. Note too the caveat in the instructions you’re following: “The following instructions are no longer up-to-date.

  • I have installed the x64 versión. Now you say I should run in some kind of compatibility mode? Or do I need to contact the programmer? Cause he takes around one week to reply to the questions we send... Or what exactly should I do to fix this? – Dem Rottensoul Jun 27 '18 at 9:19
  • The application needs to change the way it’s initialising its OpenGL context. That’s not something you can do, you need to ask the developer to take care of this. – Stephen Kitt Jun 27 '18 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.