-2

I am just trying to do an upgrade (sudo apt upgrade), but it fails with error E: Broken Packages. Doing dpkg -l | grep broken and dpkg -l | grep held returned nothing. My sources.list looks as follows:

deb http://ftp.at.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.at.debian.org/debian/ stable main contrib non-free

deb http://ftp.at.debian.org/debian/ stable-updates main contrib non-free 
deb-src http://ftp.at.debian.org/debian/ stable-updates main contrib non-free

deb http://security.debian.org/ stable/updates main
deb-src http://security.debian.org/ stable/updates main

deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main

deb https://deb.opera.com/opera stable non-free

deb http://downloads.metasploit.com/data/releases/metasploit-framework/apt lucid main

deb [arch=amd64] https://repo.skype.com/deb stable main

deb http://repository.spotify.com stable non-free

deb [arch=amd64] http://repo.steampowered.com/steam/ precise steam
deb-src [arch=amd64] http://repo.steampowered.com/steam/ precise steam

I also did sudo apt install -f, sudo apt update && sudo apt upgrade -f && sudo apt dist-upgrade -f and it didn't solve the problem. As well, I tried to use aptitude and synaptic instead of apt. I think it's all about conflicting versions of some packages, but i don't know how to solve it yet.

Full output of sudo apt upgrade:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgstreamer-gl1.0-0 : Breaks: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
 libgstreamer-plugins-base1.0-0 : Conflicts: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
                                  Breaks: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
 libgstreamer-plugins-base1.0-0:i386 : Conflicts: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
                                       Breaks: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
 libgstreamer1.0-0 : Breaks: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
 libgstreamer1.0-0:i386 : Breaks: libgstreamer-plugins-bad1.0-0 (< 1.13.1) but 1.10.4-1 is to be installed
E: Broken packages
  • Try to let the system clear things up: sudo apt-get autoremove; sudo apt-get install -f – Stefan M Jun 25 '18 at 19:22
  • Could you edit your question to include the full output of sudo apt upgrade? – Stephen Kitt Jun 25 '18 at 19:22
  • lucid is not debian stable. You're using incompatible repos. Don't mix them! – Ipor Sircer Jun 25 '18 at 19:31
  • Ok, I fixed that... But the problem is still there. – xcynthos Jun 25 '18 at 19:34
2

You’ve somehow got gstreamer packages from Debian testing or unstable. To fix your system, you should remove them and restore the Debian 9 versions:

sudo apt purge libgstreamer-gl1.0-0
sudo apt install libgstreamer-plugins-base1.0-0/stable libgstreamer-plugins-base1.0-0:i386/stable libgstreamer1.0-0/stable libgstreamer1.0-0:i386/stable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.