0

I have been playing around with my server configuration to split up my services onto different machines(sometimes in different locations) in a bid to make a more robust and secure back-end.

As it currently stands I have my web services hosted on one server which is accessible through the web. I have several sub domains setup using Apache virtual hosts on this machine to redirect to the correct services (mail, phpmyadmin etc...). The issue arises when trying to access squirrel-mail hosted on a different machine in the local network via an Apache reverse proxy on the web server, I have followed the instructions of several websites including the Apache website in order to achieve this functionality.

The problem in question is when the sub domain is loaded, the link just redirects to the default web site served by the main web server not the squirrelmail domain as desired.

My current configuration of the virtual host file for the subdomain mail.domain.com is as follows:

    <VirtualHost *:80>
        ProxyPreserveHost On
        ProxyPass / http://192.168.0.198/squirrelmail
        ProxyPassReverse / http://192.168.0.198/squirrelmail
        ServerName mail.domain.com
    </VirtualHost>

I have checked to ensure the proxy modules are enabled and working before posting and the web server has been restarted. I have been trying to solve this for some time, I believe the issue revolves around the link in the virtual hosts file, but I am unsure how to resolve this issue.

Anything I have missed or you need to know I will add ASAP, Thanks for looking! (I hope this is formatted correctly)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.