0

OS: Ubuntu 18.04 LTS
Headphones with bluetooth: JBL T450
PC: Dell Inspiron 5570

When I am watching a movie or listening a music and there is a silence my headphones are muted and just after some sound appears they are unmuted. One of the solutions is to play some sound in the background - then silence in the movie doesn't mute headphones but it's not the solution...
I checked headphones on Windows and they are not muted so I guess there is some mismatch in OS configuration.
Any idea?

0

2 Answers 2

2

PulseAudio has suspended the module after detecting that no audio has been transferred. Disable the module that does so.

To disable loading of the module-suspend-on-idle module, comment out the following line in the configuration file in use (~/.config/pulse/default.pa or /etc/pulse/default.pa):

### Automatically suspend sinks/sources that become idle for too long
#load-module module-suspend-on-idle
2
  • I am afraid it didn't solve my problem. It was only fine just after I reconfigured it like you suggested.
    – s_z_p
    Jul 5, 2018 at 19:16
  • I have two profiles in Bluetooth settings for my Headset: High Fidelity Playback(problem with mutting) and Headset Head Unit (NO problems with mutting but sound is terrible).
    – s_z_p
    Jul 5, 2018 at 19:24
0

That's the solution:

$ sudo vim /etc/pulse/default.pa
load-module module-udev-detect ignore_dB=1

More details in the Arch Wiki.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .