-2

friends, I don't know why "0.0u 0.0s 0:00.00 0.0% 0+0k 0+0io 0pf+0w" (and many lines like this) will display when I run some C shell script, but not when some others run. And I never encountered with this problem before, which won't affect my results of my program.

I think there are some problems in the following codes after I tried to debugged and searched, but I do not know what the potential problem exactly is.

set time = `saclst KZDATE f $file61 | awk '{print $2}'`

set yea61 = `echo "$time" | awk 'BEGIN {FS="/"} {print $1}'`

set mon61 = `echo "$time" | awk 'BEGIN {FS="/"} {print $2}'`

set day61 = `echo "$time" | awk 'BEGIN {FS="/"} {print $3}'`

set time = `saclst KZTIME f $file61 | awk '{print $2}'`

set hou61 = `echo "$time" | awk 'BEGIN {FS=":"} {print $1}'`

set min61 = `echo "$time" | awk 'BEGIN {FS=":"} {print $2}'`

set sec61 = `echo "$time" | awk 'BEGIN {FS=":"} {printf "%5.2f", $3}'`

And the standard output to terminal is like the following:

And the standard output to terminal is like the following:

closed as unclear what you're asking by G-Man, Archemar, Kusalananda, Rui F Ribeiro, sebasth Jun 24 '18 at 21:38

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to U&L. This is likely to be related to application pandamp.csh you are testing. missing data ? As is not a unix/linux problem. – Archemar Jun 24 '18 at 4:32
  • I have solved that by another fella. That is due to "set time" statement....!_! – MrLi Jun 24 '18 at 5:11
  • 1
    Questions about Bourne Again shell scripts are not considered to be not Unix/Linux problems here. It seems arbitrary and wrong for questions about scripts for other Unix shells to be. – JdeBP Jun 24 '18 at 10:51
2

Somewhere in your C shell script you are assuming that you can just employ a variable named time as a script variable for your own purposes. This is not the case. This variable has special semantics, as explained in the C shell manual. Employ it as if it were an arbitrary variable that you could just use, and you potentially trigger those side-effects, which are exactly as you are seeing.

  • yes, it is due to my "set time = ..." – MrLi Jun 26 '18 at 1:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.