I have a very similar problem as described in this issue, but no solution from the answers seems to help.

I did an apt update && apt full-upgrade yesterday and since then I have no output device for sound:

Sound Output

this is my alsamixer enter image description here In here it looks like it should work smoothly


Yes, I understand that KALI is not a system for beginners nor for people who seek support for basic tasks, but I did my due diligence in looking and trying solutions to my problems before I asked for help. I really do not want to complain or waste anybody's time. Switching to anything with more usability (and having KALI only as VM) would be an easy solution, but I would strip myself of the experience from solving these problems.

Some additional information

  • My last 'apt update && apt full-upgrade' was done after an interruption (due to unstable wifi) - this might be the main cause of my issue
  • After each restart and going into alsamixer, I see my sound card deselected, after I select it, there is still no sound output device to be seen
  • lspci - 00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
  • systemctl - sys-devices-pci0000:00-0000:00:1f.3-sound-card0.device loaded active plugged Sunrise Point-LP HD Audio

Things I tried:

'pulseaudio --start -vvv'

D: [pulseaudio] conf-parser.c: Parsing configuration file '/etc/pulse/client.conf'
D: [pulseaudio] conf-parser.c: Parsing configuration file '/etc/pulse/client.conf.d/00-disable-autospawn.conf'
N: [pulseaudio] main.c: User-configured server at {35cf112cdd994a898acf6d5c98c675e7}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.
I: [pulseaudio] main.c: Daemon startup successful.

'systemctl --user enable pulseaudio && systemctl --user start pulseaudio' -> no output in terminal

'pulseaudio -D'

`E: [pulseaudio] main.c: Daemon startup failed.

I tried purging and installing pulseaudio and alsamixer, brought no change to this situation

marked as duplicate by Ipor Sircer, Sparhawk, Rui F Ribeiro, Jeff Schaller, schily Jun 24 '18 at 16:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Why kali? What are you using it for? – ctrl-alt-delor Jun 23 '18 at 13:56
  • 2
    To give a tailored response - this might sound very negative, but playing music or even being able to listen to instructional videos is not the first priority of the Kali Linux project and its support community. Also, apparently the strategy they have means it's more common for things to break on upgrades in ways which are unusual and difficult to troubleshoot. If you have to ask this question, it suggests you would like a project and support community which have different priorities. – sourcejedi Jun 23 '18 at 14:48
  • 1
    Note, it is possible to run Kali in a virtual machine, and even pass-through a supported USB wifi adaptor if the Kali tool you want to use involves wireless access. – sourcejedi Jun 23 '18 at 14:49
  • You would help yourself by demonstrating the commands from that other answer and how they didn't work for you. – Jeff Schaller Jun 23 '18 at 18:17

Looking from your dmesg output, I found the correct drivers. Whilst an update may have corrupted these drivers, I think these will work. Sooo... try this. https://github.com/wkennington/linux-firmware/blob/master/i915/skl_dmc_ver1_27.bin. It looks like the right firmware for you.

If this doesn't work, look at https://askubuntu.com/questions/998520/no-sound-in-ubuntu-17-10-with-intel-corporation-sunrise-point-h-hd-audio, but

I do not think that is your problem.

How do I install a device driver provided as a .bin file? will also help you install it, as it should be a firmware. https://github.com/intel/media-driver/issues/109 is also a discussion about the specific driver.

tl;dr Download that, move it to /usr/bin/firmware, and then run modprobe alc3227 (I think, replace with proper name if I was wrong).

  • thank you, this was very helpful (too bad my 'This answer is useful' is not shown yet), what is actually meant by copy to /usr/bin/firmware? the /usr/bin/ folder does not contain the folder firmware, nor any reference to the 'skl_dmc_ver1_27' firmware. When I run modprobe alc3227 anyways, it shows me FATAL: Module alc3227 not found in directory /lib/modules/4.16.0-kali2-amd64 Thanks for the tip, but after some ~2 hours of looking into this, I still couldn't bring it to click – user1571417 Jun 24 '18 at 22:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.