0

I have this other question in which I am trying to connect to a router using a serial connection from my Raspberry PI.

I am able to see the input from the boot loading messages using minicom but it's a little bit off; the words all appear but they are not left justified.

Also eventually when the router boots up, I get a prompt which gives me a clue as to what SoC is being used on the router, ar7240> but when I try to type into the prompt minicom goes crazy and prints like 10 lines for every character I type.

I'm pretty sure I have the basics for baud correct as I pulled those out of the OpenWRT wiki for this specific router. I'm uncertain if the resister I'm using is the right one; it's definitely a 10k but I'm unsure if the watts are correct.

P.S. I'm pretty new to using minicom for this, but it for some reason reminds me of using Dialup BBS systems with programs like CommIT back in the day.

  • Can you show us what your minicom looks like. – ctrl-alt-delor Jun 23 '18 at 13:59
  • @ctrl-alt-delor I'm so new to it that I don't even know what you mean, are you referring to some sort of configuration file, or settings that get written out? – leeand00 Jun 23 '18 at 14:25
  • No I mean to show us a representation, that if you look at it, then it will appear as if you are looking at the minicom. – ctrl-alt-delor Jun 23 '18 at 19:51
1

Have you tried using screen to connect to the SoC? I find it much easier to use than minicom. Example use is screen /dev/ttyS0 9600

  • No I haven't tried that. I was also thinking of using CuteCom – leeand00 Jun 24 '18 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.