This might be unnecessary to some extent, however, I hope to make things as seamless as possible. So the question is like this: I have edited the /etc/fstab to mount two windows partition automatically at my Linux startup. However, the partitions are mounted "Removable", which means that there is eject button at their right and their icons appears on desktop, as shown in the attached figure below:

enter image description here

This is the functionality that provided for conveniently eject portable disks like USB flash disk etc, but in my case this is quite annoying to a perfectionist like me. So I'm wondering if there is any method to make the mounted disk behaves as if they were local Linux disk?

Any idea is highly appreciated. Thanks in advance!

The added lines in /etc/fstab are

# Windows10 document
UUID=1E1209231209020D  /media/bo/Document    ntfs    defaults    0   0

# Windows10 document
UUID=B4B45B4CB45B0FET  /media/bo/Download    ntfs    defaults    0   0
  • are they attached by usb ? Jun 23, 2018 at 7:15
  • @D'ArcyNader No, I have two SATA HDDs, linux mint is on one of them and windows is on another one.
    – BookSword
    Jun 23, 2018 at 7:17
  • 1
    can you add to the question how are they mapped on your /etc/fstab ? Jun 23, 2018 at 7:30
  • @D'ArcyNader Attached.
    – BookSword
    Jun 24, 2018 at 8:11
  • One of your "New Volume" drives does not have the "eject" icon to the right. What is different about that one? Are the two Windows partitions you've asked about in your question attached to a Windows machine, or are they removable drives that you've formatted as a Windows fs? In general, the "Removable" flag is set on the disk itself, and so that is where it would have to be changed. However, your question omits details that allow for a complete answer.
    – Seamus
    Jun 24, 2018 at 11:54

1 Answer 1


it does that because you are mounting them under /media .

you must change the path from /media to /mnt

something like /mnt/win_download and /mnt/win_document would work as you ask.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .