0

I am unable to make or receive calls with asterisk and google voice. I recall having used this setup years ago, so I expect it should work, but just need an ever so subtle tweak.

I can see that I am connected:

*CLI> xmpp show connections
Jabber Users and their status:
       [xx] xx@gmail.com     - Connected
----
   Number of clients: 1

With asterisk in verbose mode, this is the output I get:

*CLI>   == Using SIP RTP CoS mark 5
       > 0x7ff3b40073a0 -- Strict RTP learning after remote address set to: 192.168.1.15:4010
    -- Executing [18008008000@xx-google-out:1] Dial("SIP/xx-00000000", "Motif/xx/+18008008000@voice.google.com,,r") in new stack
    -- Called Motif/xx/+18008008000@voice.google.com
    -- Motif/+18008008000@voice.google.com-d60e is proceeding passing it to SIP/xx-00000000
  == Everyone is busy/congested at this time (1:0/0/1)
    -- Auto fallthrough, channel 'SIP/xx-00000000' status is 'CHANUNAVAIL'
  == Using SIP RTP CoS mark 5
       > 0x7ff3b4000910 -- Strict RTP learning after remote address set to: 192.168.1.15:4012
    -- Executing [18008008000@xx-google-out:1] Dial("SIP/xx-00000001", "Motif/xx/+18008008000@voice.google.com,,r") in new stack
    -- Called Motif/xx/+18008008000@voice.google.com
    -- Motif/+18008008000@voice.google.com-dce1 is proceeding passing it to SIP/xx-00000001
  == Everyone is busy/congested at this time (1:0/0/1)
    -- Auto fallthrough, channel 'SIP/xx-00000001' status is 'CHANUNAVAIL'
       > Saved useragent "CSipSimple_achill-22/r2457" for peer xx

extensions.conf:

[general]
static=yes
;writeprotect=no

; added from forum ...
writeprotect=yes

priorityjumping=no
autofallthrough=yes

[global]
;DIALOUT=9
;RINGTIME=30

[default]
include => xx-google-out
include => xx-google-in

;https://wiki.asterisk.org/wiki/display/AST/Calling+using+Google

[xx-google-out]
;exten => _1XXXXXXXXXX,1,Dial(Motif/xx/${EXTEN}@voice.google.com,,r)
;exten => _XXXXXXXXXX,1,Dial(Motif/xx/${EXTEN}@voice.google.com,,r)
;exten => _+1XXXXXXXXXX,1,Dial(Motif/xx/${EXTEN}@voice.google.com,,r)
exten => _1XXXXXXXXXX,1,Dial(Motif/xx/+${EXTEN}@voice.google.com,,r)


[xx-google-in]
exten => s,1,NoOp()
 same => n,Set(crazygooglecid=${CALLERID(name)})
 same => n,Set(stripcrazysuffix=${CUT(crazygooglecid,@,1)})
 same => n,Set(CALLERID(all)=${stripcrazysuffix})
 same => n,Dial(SIP/xx,20,D(:1))

modules.conf

[modules]
autoload=yes

;#load => chan_motif.so
;#load => res_xmpp.so

motif.conf:

[xx]
context=xx-google-in
disallow=all
allow=ulaw,g722
connection=xx

rtp.conf:

[general]
; specify start and end port range so firewall rules are easier to write
rtpstart=10000
rtpend=20000
icesupport=yes

sip.conf:

[xx]
allow=all
allowguest=no
type=peer
secret=SECRETGOESHERE
host=dynamic
context=xx-google-out

xmpp.conf:

[general]
[xx]
type=client
serverhost=talk.google.com
username=xx@gmail.com
secret=SECRETGOESHERE
priority=25
port=5222
usetls=yes
usesasl=yes
status=available
statusmessage=Asterisk Instance - Google Talk - VoIP
timeout=5
2

The asterik to Google Voice integration has been falling out of favor at Google gradually for a while. Third-party XMPP has not been officially supported since 2014-2015, and the remaining old implementations have been dis-commissioned now.

From Google Voice Help Forum

Update regarding XMPP Interop Capabilities

de Aaron G. - Product Support Manager 28/04

Starting on June 18, 2018, we will finish migrating the last of our XMPP interop capabilities for Google Voice to the new Voice platform. This migration will enable us to create powerful new VoIP features that will both benefit and delight Voice users.

If you use Google Voice with a supported device using the XMPP interop capability, please contact your vendor to determine the best migration path to avoid a service disruption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.