2

I've set up diskless client, but man does not work:

man: error while loading shared libraries: libmandb-2.8.3.so: cannot open shared object file: Permission denied

Root is mounted like this (mount):

192.168.178.20:/srv/nfsroot on / type nfs (rw,relatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,hard,nolock,proto=tcp,port=2049,timeo=7,retrans=10,sec=sys,local_lock=all,addr=192.168.178.20)

I think this has to do with locking and NFS issues. So my idea was to change to NFSv4 (which doesn't seem to work).

PS: If I mount the nfsroot at /mnt as NFSv4 and chroot /mnt manpages work.

0

I am in the process of developing a diskless Ubuntu 18.04 terminal using an NFS mounted image and ran into the same problem. In my case, the apparmor service was restricting the man command because it originated from the NFS mount and not locally.

Several apparmor=DENIED entries associated with /usr/bin/man appear in /var/log/kern.log each time the man command is attempted.

My solution was to disable the apparmor profile for the man command (usr.bin.man) on my NFS image. This can be done with the following two commands as root. Doing so allowed the man command to function properly.

ln -s /etc/apparmor.d/usr.bin.man /etc/apparmor.d/disable/
apparmor_parser -R /etc/apparmor.d/usr.bin.man

More details found at: https://www.cyberciti.biz/faq/ubuntu-linux-howto-disable-apparmor-commands/

You can get a list of apparmor managed commands and services using the apparmor_status command. Services like cupsd may not work when loaded from an NFS share if apparmor is in use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.