6

This is a really weird one and all the research I've done so far isn't panning out.

I'm trying to connect to a Windows share from CentOS 7.5.1804 to Windows Server 2008 R2 (no snickering and let's stay on topic please) share. This server:

  • has not been promoted to a domain controller
  • resides on a flat network
  • Everyone has read/write to the share (I changed this for troubleshooting)
  • the share is named MyShare

When I run this command from Linux:

smbclient -L <IP> -U Administrator

I get this:

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    IPC$            IPC       Remote IPC
    MyShare         Disk      
    Users           Disk      
Reconnecting with SMB1 for workgroup listing.
Connection to <IP> failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
Failed to connect with SMB1 -- no workgroup available

Weird. It throws an error but still lists all the shares. Googling "NT_STATUS_RESOURCE_NAME_NOT_FOUND" hasn't yielded a lot of info.

Since the share was found, I pressed on with:

mount -v -t cifs //<IP>/MyShare /mnt -o username=Administrator

It returns this:

mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

So I read the man page and this can not use mount.cifs: mount error(2): No such file or directory

...and started thinking I need to specy the version or ntlm level.

I tried this:

mount -v -t cifs //<IP>/MyShare /mnt -o username=Administrator, vers=2.0

and

mount -v -t cifs //<IP>/MyShare /mnt -o username=Administrator, sec=ntlmv2

and they both error out because of incorrect syntax... but that's what was supplied as an example on that webpage and in the man page!

Any suggestions how to get the mount command working would be greatly appreciated. Thanks!

  • maybe try setting selinux=permissive in /etc/selinux/config and look through /var/log/audit for anything related... usually it is the other way around accessing a samba server on centos/rhel 7.x from windows and if samba_share_t is not applied then you can see your shares from windows but not access them like you described. – ron Aug 15 at 13:48
  • stress-free.co.nz/… : setsebool -P allow_mount_anyfile 1 – ron Aug 15 at 13:52
0

Try to create a new folder:

mkdir /media/MGoBlue93/cifsShare

And mount to it, I think that this issue is related to permissions, and you do not have any to mount to /mnt.

  • /media is 755. So, the mkdir command above (it's also missing a -p) won't work as a user. The permission error, "mount error(2): No such file or directory" is happening because for some reason, the shares aren't being enumerated 100% correctly... see the first part of the OP. – MGoBlue93 Jun 25 '18 at 19:44
0

Use below command:-

smbclient //IP/MyShare/ -m SMB3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.