0

I recently upgraded from Fedora 23 to Fedora 27 which involved installing a new version of Chrome. I then discovered that Java was a pain to start, and in the course of experimenting I ended up telling Firefox and Chrome to open .jnlp extensions with Firefox.

Eventually I found the javaws binary and was able to tell Firefox to stop recursively opening itself and to launch /usr/java/latest/bin/javaws %U

However, Chrome still launches Firefox for every .jnlp extension (OK, it works with Firefox, but it's messy), but I've been unable to find a way to tell Chrome to use javaws instead. I've done a "egrep -ri 'jnlp|firefox' ~/.config/google-chrome" and deleted several files to no avail. I even deleted the entire ~/.config/google-chrome directory. However Chrome still launches Firefox for every .jnlp extension.

I've searched the web and everything talks about setting the default application for Windoze, but I'm running a proper OS. I even created a /usr/share/applications/javaws.desktop on that basis, but Chrome still insists on launching Firefox for .jnlp extensions.

How do I get rid of this setting and even better how do I get it to use javawa instead?

Lenovo Thinkpad T510
Linux 4.16.7-200.fc27.x86_64 x86_64

Google Chrome   66.0.3359.181 (Official Build) (64-bit)
Revision    a10b9cedb40738cb152f8148ddab4891df876959-refs/branch-heads/3359@{#828}
JavaScript  V8 6.6.346.32
Flash   24.0.0.189 internal-not-yet-present
User Agent  Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
Command Line    /usr/bin/google-chrome-stable --flag-switches-begin --flag-switches-end
Executable Path /opt/google/chrome/google-chrome

$ java -version
openjdk version "1.8.0_171"
OpenJDK Runtime Environment (build 1.8.0_171-b10)
OpenJDK 64-Bit Server VM (build 25.171-b10, mixed mode)

TIA Ken.

migrated from serverfault.com Jun 20 '18 at 21:27

This question came from our site for system and network administrators.

0

After doing an strace of Chrome I finally found the config file it was reading and it wasn't in ~/.config/google-chrome

It's in ~/.config/mimeapps.list

application/x-java-jnlp-file=javaws.desktop;

There has to be a corresponding file /usr/share/applications/javaws.desktop with the details of how to execute javaws

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.